Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Quick question?


  • Please log in to reply
10 replies to this topic

#1 Brumby Boy

Brumby Boy

    ozzy subaru nut

  • Members
  • 525 posts
  • Tsvl, QLD, Australia

Posted 02 September 2005 - 09:56 AM

I have a hell bad rattle in my 92 brumby. it sounds like tappets so i adjusted them but they are still noisy what do you think?
Stock EA81 with extractors, no cat and 2 inch hi flow system

#2 MorganM

MorganM

    Do you Subaru?

  • Members
  • 8,390 posts
  • TwinCities

Posted 02 September 2005 - 10:00 AM

Get a Mechanic (needle) Stethiscope and find where the noise is really coming from.

#3 Brumby Boy

Brumby Boy

    ozzy subaru nut

  • Members
  • 525 posts
  • Tsvl, QLD, Australia

Posted 02 September 2005 - 10:03 AM

spose i can do that tomorrow. by ear it definatly sounds like tappets and from that specific top of the head area

#4 subyrally

subyrally

    Trust your Turbo-Lust

  • Members
  • 2,888 posts
  • frederick, md

Posted 03 September 2005 - 09:53 PM

could be like my rx, the little pin for the hill holder cable rattles like hell. i thought it was a lifter till i put my finger on the pin, then the engine was quiet again.

#5 redskin

redskin

    USMB is life!

  • Members
  • 144 posts
  • Port Macquarie

Posted 04 September 2005 - 09:48 AM

Did you check the push rods? was one of your tappets loose? if so check these as they do bend.

#6 subarunuts

subarunuts

    USMB Regular

  • Members
  • PipPipPip
  • 89 posts

Posted 04 September 2005 - 05:14 PM

Check your oil pressure - the EA81's do need oil pump replacement after 100 - 150k, and you might have air in your lifters. A lot of people will just replace the seals in the pump, but really once the seals are dead and crispy chances are a new pump is needed.

#7 Brumby Boy

Brumby Boy

    ozzy subaru nut

  • Members
  • 525 posts
  • Tsvl, QLD, Australia

Posted 09 September 2005 - 07:57 AM

could be like my rx, the little pin for the hill holder cable rattles like hell. i thought it was a lifter till i put my finger on the pin, then the engine was quiet again.


Hill holder? in a brumby?

#8 Brumby Boy

Brumby Boy

    ozzy subaru nut

  • Members
  • 525 posts
  • Tsvl, QLD, Australia

Posted 09 September 2005 - 07:59 AM

Check your oil pressure - the EA81's do need oil pump replacement after 100 - 150k, and you might have air in your lifters. A lot of people will just replace the seals in the pump, but really once the seals are dead and crispy chances are a new pump is needed.


Lifters? in a EA81?

#9 subyrally

subyrally

    Trust your Turbo-Lust

  • Members
  • 2,888 posts
  • frederick, md

Posted 09 September 2005 - 09:23 AM

could the rattling be from your teeth on rough roads?

#10 MorganM

MorganM

    Do you Subaru?

  • Members
  • 8,390 posts
  • TwinCities

Posted 09 September 2005 - 09:25 AM

Lifters? in a EA81?


some EA81's had hydros

#11 Guest_shadow_*

Guest_shadow_*
  • Guests

Posted 09 September 2005 - 10:43 AM

Yes over here at least the turbos, autos and maybe the later model EA81's a lot had the hydro lifters. On my turbo EA81 I used to have there was a sticker on the valve cover that said something like "do not adjust valves" or whatever. If you used guages and set a hydro engine like you would a solid lifter engine you might to have some noise. ;)

One of the experienced EA81 guys ought to be able to tell you exactly what models/years got the hydros over here, and what is different on the procedure to set them, as I'm not sure on that.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users