Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Power window problem


  • Please log in to reply
3 replies to this topic

#1 egladman

egladman

    New User

  • Members
  • PipPip
  • 19 posts
  • Riverton

Posted 03 September 2005 - 09:56 PM

Ok here's the deal. Just bought a 86 Subaru GL-10 Turbo wagon. The car is awesome. Only has 107K on it. But I have a slight problem. When locking the doors only the 2 on the drivers side work. The passenger side work if locked by hand. What's the deal. I'm new to this forum and subaru's. Help me out if you can. BTW I got my subaru by trading a 93 Bonneville SSEi straight across. See now you know i'm nuts and I'm trying my best to deal with these crazy gas prices. Well enough rambling and just wanted to say hi and tell everyone what a great forum this is.

#2 Cougar

Cougar

    Elite Master of the Subaru

  • Members
  • 6,340 posts
  • Anchorage

Posted 04 September 2005 - 04:36 AM

The wiring in the door jamb can get damaged so you may want to check that.

#3 subyrally

subyrally

    Trust your Turbo-Lust

  • Members
  • 2,888 posts
  • frederick, md

Posted 04 September 2005 - 09:59 AM

my door locks work fine, my issue is with thee windows, they all work fine, unless i use the panel on the drivers side. i think its that the switch corrodes or something like that, the pass side window will only move slowly, but if i use the switch on the pass door, it goes up and down like its new. gotta love mystery resistance in the lines.

#4 critical_max

critical_max

    USMB is life!

  • Members
  • 167 posts
  • Eugene, Oregon

Posted 04 September 2005 - 11:00 AM

Agreed, this is probably due to corrosion on the driver's side switch. Same thing on my power windows. You could take the switch out and clean it up, probably the best way to fix it...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users