Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

RX takes another beating at the drags...


  • Please log in to reply
14 replies to this topic

#1 BoostedBalls

BoostedBalls

    Subaru Fanatic!

  • Members
  • 444 posts
  • Cornelius, OR

Posted 04 September 2005 - 12:12 PM

Yep, I got her out on the strip again last night. I did runs in low range and high range. Low range redlines in 5th at the finish line but I noticed it's a lot harder to hit the gears without grinding the teeth off. High range was a lot easier to shift but I just shift into 5th at the finish line. I get past the 60' mark in less than 2 seconds in hi or low, as long as the diff is locked.
The best I seem to be able to squeeze outta her is 14.20 seconds at 93mph. My 1/8 mile time was 9 seconds flat. It wasn't enough to take the WRX running bolt-on goodies, he ran a 13.4. But that new Cobra stayed right next to me until 3/4 of the way down the track. That was a blast!
Now it's time to install the parts I have laying around in the garage: spider intake, T3 turbo, bigger home-built intercooler, external wastegate, Crane cams ignition, then get a pair of cams ground at Delta, MegaSquirt and possibly NOS.
It was running pretty consistant in the low 14 range except for the times I grinded gears, oh, and the time I had the parking brake lighly set. DOH! It's hard to tell the difference rolling up to the line with parking brake set and the rear diff locked. I didn't notice the "parking brake" light until after the race. Oh well, it did good and everything still seems to beholding together. I got about 8 passes and still drove it onto the trailor at the end of the night.

#2 tizzle

tizzle

    Subaru Nut

  • Members
  • 606 posts
  • Bellingham

Posted 04 September 2005 - 01:32 PM

trailor?

#3 [HTi]Johnson

[HTi]Johnson

    Head Trauma, inc.

  • Members
  • 1,512 posts
  • Coburg, Or.

Posted 04 September 2005 - 03:32 PM

Yeah, what the heck is a trailor! Oh the thing I use to tow my dirtbike with my wagon. What do you have done to that bad boy?

#4 FirstSubaruGLwagon

FirstSubaruGLwagon

    YHWH is life

  • Members
  • 458 posts
  • Wilmington

Posted 04 September 2005 - 11:28 PM

DOH! It's hard to tell the difference rolling up to the line with parking brake set and the rear diff locked. I didn't notice the "parking brake" light until after the race.

make a break indicator light on the dash maybe,,, or put a higher watt bulb in the exsisting indicator. just little friction can ad seconds

#5 BoostedBalls

BoostedBalls

    Subaru Fanatic!

  • Members
  • 444 posts
  • Cornelius, OR

Posted 05 September 2005 - 02:34 PM

The RX is an insurance total in WA and a HUGE pain to get titled/registered. The car is totally streetable and I would love to get it registered so I can do road tuning and save on gas. I've been driving an Astro van to work, blah...

I'll put a glasspack on it, right now it just has an open 2.5" section of pipe that goes almost to the transmission crossmember. She's a bit noisy.

I'm so tempted to do a VIN switcharoo just so I can drive it on the street.

The parking brake light was on but I just didn't notice. I felt the car dragging a little bit when I was getting staged but I thought it was the locked diff in the rear.

#6 archemitis

archemitis

    guy smiley

  • Members
  • 3,554 posts
  • the big minnie

Posted 05 September 2005 - 05:07 PM

drag racing is cooler than offroad, rallyx and street racing all put together.

#7 Myxalplyx

Myxalplyx

    Old Wise and Dumb

  • Members
  • 1,834 posts
  • New Castle

Posted 10 September 2005 - 05:59 PM

Boosted,

I never congratulated you on your time. Congrats! Nice times! I wonder who'll be the first into the 13's on here?

#8 BoostedBalls

BoostedBalls

    Subaru Fanatic!

  • Members
  • 444 posts
  • Cornelius, OR

Posted 22 September 2005 - 12:00 PM

What??? We don't have any ea-82 guys in the 13's yet??? We just stepped up the challenge a bit uh? Ok, here goes the water injection and 6th injector. Time to pull the pin on this grenade.
Turns out that my boost was pegging the 20psi boost gauge at the top of the track and cutting the ignition. I'll turn it down a little bit and dump in some more unmetered fuel with water/alky mix to see what happens. This thing leaves the line like mad then kinda looses juice at the top of the track. That is why I get 1.94 second 60' times and 9 seconds flat in the 1/8 mile at 75mph but only reach 93mph in the 1/4 mile.

I'm working on an equal length stainless header for my T3 setup, it's about half done. I'll post some pix when I get er done. The primaries point at 45 degrees and meet towards the front of the car then turn and head back to the passenger side. I'm thinking about plumbing the wastegate right next to the oil filter and have it dump towards the right front tire. That should be obnoxious enough.

#9 mattyg41383

mattyg41383

    USMB is life!

  • Members
  • 154 posts
  • Cheshire, MA / Troy, NY

Posted 22 September 2005 - 06:03 PM

My 60' times were only like 2.2 or something might even be slower than that, I gotta check my books. ((Running through a 2WD auto)) Same issue with it launching like a beast till half track, then it just kind of runs out of steam. Got some ideas for winter to get it back into shape....

I too was wondering if anyone had gotten into the 13's. I'm at 14.5 right now.

I have the same issue with the title. My XT was brought down to my dad's shop by another place because they couldnt get it running. They then went out of business soon after and the car stayed with us. Turns out it had 1 snowmobile spark plug in it, quick swap and it worked like a charm.

#10 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 22 September 2005 - 06:15 PM

I might go out to the 1/4 soon.....

#11 BoostedBalls

BoostedBalls

    Subaru Fanatic!

  • Members
  • 444 posts
  • Cornelius, OR

Posted 22 September 2005 - 06:23 PM

Right on, The automatic might actually be helping your times because you don't have to take your foot out of it and dump boost but the 2wd is killing your launches. Either way, sounds like it's working pretty damn good. What psi did you set your 5th injector at? Mine is at 12 psi and I'm about to install another one to come on at 17psi. I just want to see what this stock engine, turbo, cams combo is capable of. I have a fresh engine on the stand in my garage that's getting the works. Ported spider intake, ported heads, delta cams, equal length header, external wastegate, etc,etc. Nothing like whipping some V8s with an 80's 4 banger. My engine is running pretty rough right now though, sounds like crap until it warms up. I hope the 20psi+ spikes (that I didn't notice in the late night drags because I don't have a light on my boost gauge) didn't do any damage to the engine.

#12 mattyg41383

mattyg41383

    USMB is life!

  • Members
  • 154 posts
  • Cheshire, MA / Troy, NY

Posted 22 September 2005 - 06:31 PM

Yeah I suffer at the launch -> 60' cause of the auto but further on down it keeps the boost up. Although last time I was only getting like 14psi out of it, when it should been at about 18psi from how it was last year... I gotta play around with my new MBC at get that working right, quit messing with the bleeder.

Ive got the 5th tripping at like 13-14. I dont know exactly cause last time out we had it early and then just turned the screw out until i was happy. Didnt check the exact psi on that.


Sounds like quite the engine you've got going there. Weve got a T3 sittin around we might work with over winter, but this year we're just gonna fiddle with the current 'stock' setup and see what it'll do. I want to get a torque converter modified, and maybe do some headwork. Ive got a lot of irons in the fire right now with school and working and stuff so no major projects until winter.

#13 mattyg41383

mattyg41383

    USMB is life!

  • Members
  • 154 posts
  • Cheshire, MA / Troy, NY

Posted 22 September 2005 - 06:36 PM

Chuck --- Forgot to ask before, Do you know how much your car weighs?

#14 soobmater

soobmater

    Got Mud?

  • Members
  • 1,668 posts
  • South Bend

Posted 22 September 2005 - 06:55 PM

congrats on the time, that s fast considering mine will do a 1/4 mile in about 10 minutes:lol:

#15 BoostedBalls

BoostedBalls

    Subaru Fanatic!

  • Members
  • 444 posts
  • Cornelius, OR

Posted 02 November 2005 - 07:27 PM

I haven't weighed the car yet but it should be pretty close to stock, whatever that is. Brad stole the rear seats, carpet, other than that; I've added a few lbs under the hood with the WTAIC setup. No spare tire, no roll cage.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users