Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Hey soobies


  • Please log in to reply
1 reply to this topic

#1 flatfourfuji

flatfourfuji

    New User

  • Members
  • Pip
  • 2 posts
  • Norton, New Brunswick CDA

Posted 19 September 2005 - 08:34 PM

I am just new to your forum but have already solved some problems with my car. I had the ''sticking clutch pedal/slave cylinder'' problem that my dealer had never heard of. Amazing that the replacement parts were on his shelf and the repair worked perfectly. I have an '01 Legacy GT sedan and am now having problems with engine idle, sometimes to 3500rpm in between shifts and I find myself picking up speed on level highways. Once again, my dealer says he has never heard of this before, but adds that it is common on most 5spd mt. I feel like I have to find a solution to take to my dealer to have them fix anything correctly. I should have known when they never checked the ATF on my '99 Legacy SE wagon for almost 3 years, despite charging me for ''scheduled maintenance''. I love the cars, I hate the service. My wife drives an '04 Forester X with the hill holder and 5spd mt. That really threw the dealer when I asked them to adjust it because it was binding the brakes too tight (would stall even on flat ground and sounded like the E-brake was on) With help from your forum, it is now adjusted correctly. I will soon be 'introducing' a 2.2 to a 1975 VW Beetle for added pick me up and who knows, maybe I will soob-up an Austin Mini,if it will fit. Anyway, if anyone can offer a suggestion to my idle probs, I would appreciate it.

Flat Four Fuji

04 Forester X
01 Legacy GT Sedan
2-1975 VW Beetles
1954, 1955 Beetles

#2 nipper

nipper

    Semi Elite Master of the

  • Members
  • 17,603 posts
  • Long Island NY

Posted 19 September 2005 - 09:07 PM

I think you need a new dealer. These are not impossible problems. Find somone who wants your business. Next youll go in with a CEL or flat tire and hell say he never heard of that problem.


Joe




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users