Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

MegaSquirt....


  • Please log in to reply
30 replies to this topic

#1 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 25 September 2005 - 07:19 PM

Finally, I have one...

We solded the harness up tonight, and we got it to idle.

Next step is tomorrow night, at the shop we will instll the IAT sensor, and tune it on the dyno.

HUGE thanks to http://www.diyautotune.com/ for the hardware and soldering services!

#2 JWX

JWX

    Lonely driver

  • Members
  • 3,073 posts
  • Atlanta

Posted 25 September 2005 - 07:32 PM

cheater

#3 subyrally

subyrally

    Trust your Turbo-Lust

  • Members
  • 2,888 posts
  • frederick, md

Posted 25 September 2005 - 07:53 PM

what unit did you get?

#4 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 25 September 2005 - 08:23 PM

The latest and greatest ofcourse.

#5 jeffast

jeffast

    f*** im 24

  • Members
  • 2,029 posts
  • midwestren

Posted 25 September 2005 - 08:32 PM

i've been looking at mega squirt how hard was it to install?

also KICK@$$

#6 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 25 September 2005 - 08:39 PM

its NOT plug any play....yet. Plug and play kits will be avalible for Leone's soon....exclusively thru WJM Rallye Sport. This is the experimental/prototype unit.

WJM

#7 subyrally

subyrally

    Trust your Turbo-Lust

  • Members
  • 2,888 posts
  • frederick, md

Posted 25 September 2005 - 09:02 PM

its NOT plug any play....yet. Plug and play kits will be avalible for Leone's soon....exclusively thru WJM Rallye Sport. This is the experimental/prototype unit.

WJM



any idea of what the pricing will be??


that will be hot

#8 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 25 September 2005 - 09:07 PM

about.....alot.

Lets just say...more than $400, and less than $800. My kits might include a wideband setup for autotune, so that will adda bout $200 onto the cost.

#9 Guest_shadow_*

Guest_shadow_*
  • Guests

Posted 25 September 2005 - 09:10 PM

Whenever I bring my kits to market, I'll be sure to sharply undercut WJM here! :lol:

Good job on getting it running, now get it tuned!

#10 jeffast

jeffast

    f*** im 24

  • Members
  • 2,029 posts
  • midwestren

Posted 25 September 2005 - 09:22 PM

nm i'm stupid

#11 oddcomp

oddcomp

    Subaru Master

  • Members
  • 1,763 posts
  • longview ,wa

Posted 25 September 2005 - 09:39 PM

nice. :)

#12 subyrally

subyrally

    Trust your Turbo-Lust

  • Members
  • 2,888 posts
  • frederick, md

Posted 25 September 2005 - 10:27 PM

about.....alot.

Lets just say...more than $400, and less than $800. My kits might include a wideband setup for autotune, so that will adda bout $200 onto the cost.



will that be including the ms box or is that just the adaptor kit?

#13 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 25 September 2005 - 10:55 PM

It will be the complete kit....remove stock ECU, plug up the MS, tune and have fun.

Whenever I bring my kits to market, I'll be sure to sharply undercut WJM here! :lol:

Good job on getting it running, now get it tuned!


ha...ha...ha....

at this rate i dont think WJM Rallye Sport is going to get off the ground for quite a while...all Leones world wide might rust away. LOL

#14 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 05 October 2005 - 10:28 PM

Tonight we played some more with it....it is currently idling like OE...which means steady ~1000 RPM idle...no missing. Just smooth idle. :banana:

Next...more idle and crank-start tuning...then off to the dyno to tune.

#15 Snowman

Snowman

    Midnight Passenger

  • Members
  • 3,538 posts
  • Haines

Posted 05 October 2005 - 10:49 PM

That is so sweet. If I ever build up an EA82T, this is going to be high on my list.

#16 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 08 October 2005 - 10:41 PM

Ok, so we are up to 113/133 as compared to stock 106/129....

still lots more to do.

and YES...the MS is in, and working perfectly.

#17 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 09 October 2005 - 01:31 AM

well, 116hp/140tq are the semi-final numbers.

thats 10hp and 6tq increase. Off boost power is a ton better...and butt dyno on the street says its really around 20hp/15tq increase.

A lot left to do.....throttle enrichment during driving is way off....its got a weird timing stumble between 2000 and 3000...and MS-2 doesnt feature knock system monitoring or control at all...that's got me stopped on tuning.

the 12x12 table....lacks....fine resolution. I could not get the AFR's smooth...but they are better...no more pig rich....mostly 10.5~11.5 in boost. tried to get 14.7 everywhere else...but it smooths from 14.7 to 12 when comming into boost...then from 12 to the sweet spot range for boost.

Timing is...set...to...alot. I need knock system stuff damnit!

#18 oddcomp

oddcomp

    Subaru Master

  • Members
  • 1,763 posts
  • longview ,wa

Posted 09 October 2005 - 08:32 AM

where are my fuel maps bish?!?!?!? lol

certainly worth the hassle of making it work huh :)
pay attention and you should notice the turbo coming in a little to alot sooner
especially if you add a a little extra fuel in the 90-100 kpa range

you want a copy of my timing maps? to see if that helps ?
they are pretty much tuned by ear and feel and engine temp but seem to work fine for me for now until i get rich and can play on a dyno
maybe i can con some dyno place up in pdx in giving me a break for it being such a one off setup lol

#19 joostvdw

joostvdw

    Subaru Nut

  • Members
  • 609 posts
  • Holland

Posted 13 February 2006 - 05:16 PM

Maybe one of you guys running MS2 could write-up what is needed to install it on a ea82t? Like all the connections and hickups you've obviously solved.

Would be great for future users of MS2

thanks in advance

#20 Dylan86GL10

Dylan86GL10

    USMB is life!

  • Members
  • 226 posts
  • Tidewater, VA

Posted 27 February 2006 - 11:47 AM

What spark trigger are you using? Distributor or EDIS?

#21 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 28 February 2006 - 01:00 AM

the stock Disty...and usisng it to disty the spark.

Or...was...since there's an EJ22E going in now..

#22 Dylan86GL10

Dylan86GL10

    USMB is life!

  • Members
  • 226 posts
  • Tidewater, VA

Posted 28 February 2006 - 09:06 AM

the stock Disty...and usisng it to disty the spark.

Or...was...since there's an EJ22E going in now..


Thanks, that was my plan for now.

#23 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 19,612 posts
  • WV

Posted 01 March 2006 - 09:04 AM

dylan,
are you installing MS on your EA82T?
you're going to have MS and EDIS?
have you started yet?

#24 Dylan86GL10

Dylan86GL10

    USMB is life!

  • Members
  • 226 posts
  • Tidewater, VA

Posted 01 March 2006 - 10:54 AM

dylan,
are you installing MS on your EA82T?
you're going to have MS and EDIS?
have you started yet?


Gary, I have a spare MSnS'e that I built a couple years ago. One is on my Neon but I haven't mounted or wired the spare on the wagon yet. I don't know if I'm going EDIS or distributor. As I have the 86 distributor I don't know how I'm going to address the constant spark signal. I'm still pretty new to subaru but I believe the 86 turbo distributor still has mechanical advance and not computer controlled (separate knock box). I could pin the advance so the signal out of the distributor is always at TDC. Getting the EDIS parts doesn't bother me but then I still need to machine and mount the crank wheel.

Actually this weekend, there is the big MegaSquirt get together in Virginia Beach with the designers and folks from all over the country. We are meeting up at a dyno shop Saturday and Sunday.

There should be details here:
http://www.msefi.com...ghlight=#104803

#25 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 19,612 posts
  • WV

Posted 01 March 2006 - 10:57 AM

sweet, nice. i'd like to do this to the XT Turbo once it's up and running.

is this set-up reliable? or constant maintenance?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users