Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

3 in hose


  • Please log in to reply
No replies to this topic

#1 tcspeer

tcspeer

    1000+ Super USER!

  • Members
  • 1,444 posts
  • Walnut Springs

Posted 04 October 2005 - 09:52 PM

The heater core in my right wheel drive Subaru has about a three in. hose connecting the inlet tube to the heater core, right next to the core. That is where mine was leaking the core was fine, but I put the new one in anyway. I dont know why the whole pipe on the core wouldnt be copper but it was not. Does the one for reg. drive have this peice of hose?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users