Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

98 Forester check engine light.


  • Please log in to reply
1 reply to this topic

#1 coolconnection

coolconnection

    New User

  • Members
  • Pip
  • 1 posts
  • eastern ohio

Posted 22 October 2005 - 01:30 AM

Hello everyone!!!

This is my first post on this site and I would like to say hello. I have been reading other posts and doing searches for my vehicles problem. I have had it to two separate places, one for a radiator flush and the other was auto zone. My check engine light will go off for a couple days and then come on for a couple of days. If it is off and I make a left turn it WILL come on again. It came up after being tested for egr system on the code reader and I don't remember the code number. I have read some other posts and most of the problems are the selenoid but I can't find it under the air intake. I found a small selenoid under (I think it is call the cylinder head manifold) what ever it is, it is a big shiny thing on top of the engine. Could this be it and can a selenoid be cleaned or does it have to be replaced? I have 106,000 original miles on it but I hate that light being on most of the time. I am so close to just ripping out the stupid bulb but I think it is more difficult to reach than fixing the problem. If anyone has any info or remarks please post them.

Thanks in advance.

#2 Legacy777

Legacy777

    Moderator

  • Moderator
  • 12,654 posts
  • Houston, Tx

Posted 23 October 2005 - 12:31 PM

You need to find out the specific code that is being stored. That will make troubleshooting the problem easier.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users