Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

front strut blues at imperial dunes california


  • Please log in to reply
3 replies to this topic

#1 Rooinater

Rooinater

    Official Thread Killer...

  • Members
  • 2,285 posts
  • Gig Harbor

Posted 28 September 2003 - 06:58 PM

dunes are rad!! :banana: but once again another strut bites the dust. i wasn't going too fast this time around but a few to many whoops at the bottom of a hill started to pogo me back to front. and in the process of trying to slow down more it poped. that's # 3. i need to find away to reinforce these things. or be nicer to them.

i almost shot off a 60 foot razor back dune!! :eh: luckinly i was only going like 10 to 15 mph at the time.

got to get my camera fixed so i can take pictures of my car out in this area. lots of rock and sand here in the sw.

#2 Qman

Qman

    Happiness is... no lag!!

  • Moderator
  • 11,119 posts
  • Sumner

Posted 28 September 2003 - 07:44 PM

Jared, try changing out that hub as well. There has to be a reason that they aren't holding. Is the bolt that goes through the knuckle/hub threaded all the way? If not that could be the problem.

Sounds like fun right up to that point.

Ken

#3 Adam N.D.J.

Adam N.D.J.

    Quite Rusty, but working.

  • Members
  • 3,268 posts
  • Medford, Oregon

Posted 28 September 2003 - 11:06 PM

Oh yeah, dunes rock!! I love taking the Brat out to the Oregon dunes in Coos Bay. Whot exactly happened to your strut? Cause I had some problems with one of mine last weekend, it kept sliding out of the knuckle.

#4 Rooinater

Rooinater

    Official Thread Killer...

  • Members
  • 2,285 posts
  • Gig Harbor

Posted 29 September 2003 - 12:51 PM

it's not at the bottom of the strut. i replaced that hub when the bolt backed out. :( it's the top bushing part. this is the third one that has torn out. and they alternate sides :( the first was the drivers side, the second the passenger then now the drivers side once again. what it's doing is seperating the strut from the top mount just tearing that bushing??? the first 2 times it shoved the strut through the fender. this time it just mearly poped out.

i pushed it back in the hole and drove home. it's driving me insane i seem to be the only one with this problem. i need to find a way to reinforce, cause so far the junkyard prices are hellacious!! :madder:

lots of fun!! i'm getting a new strut wednesday, they want too much but i have to pay it, i guess...
then on saturday i'm planning on running up to superstition mtns, to try the knock on wood trail, most diff rock crawlin' trail :brow: see how far i can make it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users