Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Please help! Check engine light on and cruise flashing


  • Please log in to reply
5 replies to this topic

#1 lovemyoutback

lovemyoutback

    New User

  • Members
  • Pip
  • 2 posts
  • Tulsa

Posted 12 December 2005 - 07:02 PM

I have a 2005 Outback...

The other *very cold* night the check engine light came on and the cruise light started flashing (cruise would not work either). I thought it might get better once the weather warmed up a bit. It did (both lights went off), but this morning it started doing the same thing again. This was not a really cold morning, so my original theory isn't seeming plausible.

Has anyone experienced this and do I need to have it checked out?

Thanks for any help you might be able to offer,

Paige

#2 sea#3

sea#3

    Subaru Fanatic!

  • Members
  • 354 posts
  • Vancouver Canada

Posted 12 December 2005 - 09:05 PM

Your car has thrown a code and that is why the Check Engine light is on aswell as the cruise light- which will flash
The reason the Cruise Control doesn't work is because of the code . You car is a "drive by wire " on the throttle . when there is a code in the memory, it goes into a fail safe mode -will not operate
Go to the dealer and get them to scan for the code

Hope this helps
SEA#3

#3 lovemyoutback

lovemyoutback

    New User

  • Members
  • Pip
  • 2 posts
  • Tulsa

Posted 13 December 2005 - 09:02 AM

Thanks for the advice - I'll make the trek into the dealer.

#4 Cougar

Cougar

    Elite Master of the Subaru

  • Members
  • 6,340 posts
  • Anchorage

Posted 13 December 2005 - 10:34 AM

One of the benifits of owning a new car is that problems like this are covered under warranty and they are the dealers reasponsibility to fix. Hopefully they will have a loaner car for you to use while yours is in the shop.

#5 MarkJ

MarkJ

    New User

  • Members
  • Pip
  • 1 posts
  • San Jose, CA

Posted 09 January 2006 - 02:15 PM

Thanks for the advice - I'll make the trek into the dealer.


So what was the outcome? This just happened to mine as well. It did seem like my wife did not tighted the gas cap correctly. I am going to disconnect the battery tonight to reset the computer and see if the problem reappears. I was just curious if the dealer told you it was a different problem.

#6 brus brother

brus brother

    Subaru Master

  • Members
  • 1,879 posts
  • Connecticut

Posted 09 January 2006 - 05:17 PM

Last week my wife's 05 OB Automatic ground to a halt with CEL and cruise control a flashin'. Short story... tranny toast. New one coming. We've got an 06 loaner and a courteous dealer..




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users