Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

1988 GL-10 Turbo Problem


  • Please log in to reply
3 replies to this topic

#1 SeattleSubieNubie

SeattleSubieNubie

    New User

  • Members
  • Pip
  • 5 posts
  • Seattle

Posted 02 January 2006 - 07:07 PM

I'm a first time Subaru owner and first time turbo owner. Under harder acceleration at highway speed the turbo causes the engine to hesitate and black smoke comes out the tailpipe.

Do any of you knowledgable folk know what the problem is? how much it should cause to have it fixed? or if I can just have the turbo turned off?

Also, is there anyone in the Seattle area who feels experienced enough to replace my CV joints for a little cash?

Thanks for your help!

#2 4WDFrenzy

4WDFrenzy

    Certified Subaru Nut

  • Members
  • 857 posts

Posted 02 January 2006 - 08:33 PM

What is the condition of your air filter? If it is dirty, it can cause hesitation as I have seen it happen before. Also plugged fuel filter, dirty Mass Airflow Sensor, dirty fuel injectors, or possibly ignition timing issue come to mind. This might give you a couple places to start troubleshooting.

As far as the turbocharger, you can't turn it off as it runs off of exhaust pulses. You can remove it and I would venture to guess that it is possible to install an NA manifold, but it would run like a dog and power loss as a result would be very significant, leaving you very unhappy with it at best.

Patrick

#3 nkx

nkx

    Rallycross Junkie

  • Members
  • 891 posts
  • Carlisle, PA

Posted 03 January 2006 - 04:14 AM

is your car an auto or a manual? you could also try replacing the pcv valve. seems a lot of folks have seen black smoke when getting on/off of ramps with sweeping turns.

#4 orochigami1

orochigami1

    Newbie

  • Members
  • Pip
  • 2 posts
  • el paso texas

Posted 24 May 2014 - 12:34 PM

Hello I have almost the same problem i have not been able to get a kit to rebuild the turbo charger i took my gl 10 to a mechanic due to gray smoke from the tail pipe it seems the turbo charger is damage and is liking oil in to the exhaust system there for the smoke can any one help me 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users