Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Non working hazard flashers


  • Please log in to reply
2 replies to this topic

#1 caplij

caplij

    New User

  • Members
  • Pip
  • 8 posts
  • Severn, MD

Posted 18 January 2006 - 09:04 PM

Hi,
I just found this group - looks interesting. I have a 1998 Legacy Postal with right hand drive. The hazard flasher and the automatic antenna have stopped working. I checked all the fuses and they are good. This has happened before. Two years ago the same thing happened and the dealer charged me $265 to "solder a broken wire to the hazard switch" and it took three days to get the car back. Does anyone have a wiring diagram or could suggest an idea of where this defective connection could be. I would like to try and fix it myself if possible. $$$$ are kinda scarce if you know what I mean.

John

#2 85Sub4WD

85Sub4WD

    EA82 Junkie

  • Members
  • 1,244 posts
  • Raleigh NC/Charlotte NC

Posted 18 January 2006 - 10:37 PM

I do not know legacys (this is the old-gen forumn - pre legacy, impreza, etc)
however, do your turn signals work? if they don't I would bet money on the flasher unit (if your car has one - probably does) if not, I do not know

#3 caplij

caplij

    New User

  • Members
  • Pip
  • 8 posts
  • Severn, MD

Posted 18 January 2006 - 11:17 PM

Turn signals work fine- actually everything else works except the radio antenna and the hazard flashers. I didn't realize I was in the wrong forum. Is there a way to move this to the right one?

john




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users