Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

no spark after engine swap


  • Please log in to reply
1 reply to this topic

#1 dancn

dancn

    New User

  • Members
  • Pip
  • 1 posts
  • ireland

Posted 25 January 2006 - 11:59 AM

Hi all,
Just been told about this site, looks great.

my 1st post, and newbie needs some info::-\............

I need some information (schematics) on the old distributor + coil ignition system from the early '90s legacy EJ18.
I recently fitted a 1990 Legacy N/A (carb) EJ18 engine into a project car.

The project car does not have a suitable wire loom for this engine, so I'm making a temporary loom to make the engine run.

I have fuel but no spark; the engine ran before I removed it from the Legacy.

I followed the wires before I removed the engine,

there are 2 wires to the coil, one a yellow, ( 12V+ supply, I think) which also feeds to the the distributer, then to a capacitor. The other coil wire is black/blue+red which also goes to the distributor, (changes to black/white at connector)
the black/blue wire comes (as does the yellow) through the bulkhead from the inside of the car.




I want to figure out where this black/blue+red wire connects inside the car. (Before removal, I cut this wire just outside the bulkhead, with the engine running, and it didn’t stop!, so I assumed I would NOT need it, I thought it was just for tacho)
I have the yellow conencted to +12v, yet I don't have a spark at the plugs, but it did with the black/blue+red wire cut??

This is confusing me some, If I had a schematic I could maybe figure this out

This ignition circuit is probably found on other models form late '80s, early '90s
Basically I have +12v to the dis and coil, but the other wire common to both dis and coil is not connected, should it be grounded?



Thanks for any help.

#2 Legacy777

Legacy777

    Moderator

  • Moderator
  • 12,563 posts
  • Houston, Tx

Posted 25 January 2006 - 01:01 PM

This is the closest thing I can get ya that might help
http://www.driftqueb...1992_legacy.pdf

It's for the overseas 92 legacy. We didn't get the 1.8 distributor engine for the Legacy here in the states.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users