Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

suspension (air) code read outs(?)


  • Please log in to reply
3 replies to this topic

#1 c150L

c150L

    Subaru Nut

  • Members
  • 532 posts
  • East Central Wisconsin

Posted 12 October 2003 - 04:13 PM

Can not find the thread. Quite some time ago I saw a thread here on air suspension code read outs. I was thinking that at least one of my rear struts had sprung a major leak. Now, I'm thinking this may not totally be the case. Does anyone know if an 89 XT-6 with air suspension is capable of reading out the codes some way? If so, how is it done? Then, what do the codes mean. I remember that some do, some don't and even perhaps an older vehical may have the newer CPU installed? Any insite on this would be appreciated.

#2 electryc_monk

electryc_monk

    Air-ride Airehead

  • Members
  • 1,581 posts
  • Denton, Tx

Posted 12 October 2003 - 10:38 PM

the ECU on the rear deck underside to the passener side of the sparetire. has the LED for engine codes.

It also does the air ride code ? Or maybe I'm thinking of the Wagon's ECU. SOrry, just this second i realized I'm not sure which car's setup will do the codes.

The technique in one involves the turning of the ignition on with the code test pluged in and then cycling off the ignition for like 10 seconds....

if you can wait a couple day's i;'ll be able to look it up in the FSM's and give a page reference AND hopefully a brief reference to the test.... unless someone else is faster.


gezzz sorry to get your hopes up.... right off the bat.

#3 c150L

c150L

    Subaru Nut

  • Members
  • 532 posts
  • East Central Wisconsin

Posted 13 October 2003 - 09:45 PM

Hey, I drive an air suspension Subaru. I'm used to that. LOL

Thanks and I'll watch for future posts.

I'm thinking my air compressor is acting up. It may not be starting itself up all the time when it's supposed to. I hear some clunking sounds up there and see the lights dimming in beat with those clunks. Bright, clunk, dim, bright, clunk, dim.......

Still interested in the code readouts, even if the ECU does not do this suspension. I have something engine related going on too.

Thanks again.

#4 electryc_monk

electryc_monk

    Air-ride Airehead

  • Members
  • 1,581 posts
  • Denton, Tx

Posted 19 October 2003 - 11:43 AM

For some reason - I can quite put my finger on it but - I can't find what I was looking for in the FSM's.


There was a section on testing the hight control system with the use of the ingition and the switch on the dash. How ever that would intuit that its for the Sedan and Wagon models of GL-10 only and not for the XT6 unless your in Canada :>) - for they are the only country where they put the hight button in the XT6's with air ride suspensuions.

The technique was to put switch in normal mode then wait for it to level out with the ingition is full on(just not running) position wait something like 10 seocnds and then turn ignition off

then push in the hieght switch and turn ignition back on.
wiat 10 seconds then turn off ignition again

then push swtich one last time and then turn on the ignition wait till 10 more seconds then reboot.

Something about this allows me to see it blink (the LED on the
engine MPFI box) to blink at a significantly




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users