Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Clutch judder...cable tired??


  • Please log in to reply
2 replies to this topic

#1 Setright

Setright

    Elite Master of the Subaru

  • Members
  • 3,176 posts
  • Denmark

Posted 13 October 2003 - 05:51 AM

Okay, so since I replaced my clutch at 125k miles I have been experiencing the dreaded j-u-d-d-d-d-er! However, I also seem to get it even when everything is warmed up, though to a lesser degree.

My car will not crawl along using the clutch only, the throttle needs to be co-ordinated VERY carefully to avoid the vibes.

SO, does anyone think it might help to replace my clutch cable? It ain't broken, but maybe I should fix it and see? Bear in mind that here in over-priced Denmark the cable costs about $80 !!

As far as I know it's the original cable and the odo is almost at 186k miles. The pedal is quite heavy, and presumably this is due to resistance in the cable assembly. I replaced the "initial pedal effort reduction spring" not long along, because the old one cracked.

Any thoughts?


Oh, by the way, despite showing the dealer the clutch TSB, I have had no succes in getting a warranty fix on that. Dealer insists that my clutch is a different part ...

#2 Setright

Setright

    Elite Master of the Subaru

  • Members
  • 3,176 posts
  • Denmark

Posted 14 October 2003 - 12:50 AM

bump

#3 sprintman

sprintman

    USMB Regular

  • Members
  • PipPipPip
  • 105 posts
  • Canberra Australia

Posted 14 October 2003 - 02:20 AM

Find a new dealer! Mine did clutch and slave cylinder TSB 6mths after warranty expired for free.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users