Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Aftermarket Gauges


  • Please log in to reply
11 replies to this topic

#1 SyntheticBlinkerFluid

SyntheticBlinkerFluid

    USMB Regular

  • Members
  • PipPipPip
  • 79 posts
  • Beecher

Posted 23 March 2006 - 01:12 AM

I would like to see some pics of what you guys have done with aftermarket gauges. I have never been one to trust the factory oil, temp, and voltage gauges, especially in a 20 year old car that sat around in a field for 5 years.

So I'd like to see where you guys have installed them on EA82s.

#2 rllywgn

rllywgn

    Diff Lock Dynamite!

  • Members
  • 381 posts
  • Vegas Baby

Posted 23 March 2006 - 01:20 AM

heres mine... wal-mart bought Equus gauges in a homemade gauge pod..

Posted Image


rllywgn

#3 GeneralDisorder

GeneralDisorder

    Elite Master of the Subaru

  • Members
  • 20,280 posts
  • Portland

Posted 23 March 2006 - 01:35 AM

I got one of the equus guages too - the silly tubing for the oil pressure isn't really long enough tho - how did you do it? Get more tubing? Whats a source for 1/8" tubing - home depot only carries down to 1/4"....

GD

#4 kingbobdole

kingbobdole

    Mr. XT-6

  • Members
  • 1,651 posts
  • Longmont

Posted 23 March 2006 - 01:56 AM

Posted Image

#5 kingbobdole

kingbobdole

    Mr. XT-6

  • Members
  • 1,651 posts
  • Longmont

Posted 23 March 2006 - 02:26 AM

I got one of the equus guages too - the silly tubing for the oil pressure isn't really long enough tho - how did you do it? Get more tubing? Whats a source for 1/8" tubing - home depot only carries down to 1/4"....

GD

My NAPA carries it on the shelves... copper too:banana:

#6 rllywgn

rllywgn

    Diff Lock Dynamite!

  • Members
  • 381 posts
  • Vegas Baby

Posted 23 March 2006 - 06:12 AM

call me crazy but i drilled a hole through the back of the spare tire carrier... with the glove box out you can see where the firewall humps in for the spare. I knocked it from the inside with a screwdriver then drilled it through the outside... the oil line runs into the center air vent, then out a small hole above the glove box, then through the firewall... im on a tight budget so i worked with what i had..


rllywgn

#7 suberdave

suberdave

    www.suberdave.com

  • Members
  • 1,001 posts
  • Covington

Posted 23 March 2006 - 09:33 AM

here is my A-piller pod

Posted Image

-=Suberdave=-
www.suberdave.com

#8 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 23 March 2006 - 12:56 PM

Posted Image

#9 keltik

keltik

    Clearly an idiot

  • Members
  • 578 posts
  • New Zealand

Posted 23 March 2006 - 04:36 PM

Posted Image


OOOH Shiney!!! :slobber:

#10 kingbobdole

kingbobdole

    Mr. XT-6

  • Members
  • 1,651 posts
  • Longmont

Posted 24 March 2006 - 12:56 AM

Hey!
I have that stereo.

#11 Caboobaroo

Caboobaroo

    USMB Drunk

  • Members
  • 6,880 posts
  • Oregon City

Posted 24 March 2006 - 01:00 AM

here is my A-piller pod

Posted Image

-=Suberdave=-
www.suberdave.com


HEY! That looks like my gauge pod!

#12 Phizinza

Phizinza

    Yip yip

  • Members
  • 3,867 posts
  • South Australia

Posted 24 March 2006 - 01:45 AM

I know its not a EA82, but you could do the same for a EA82!

Posted Image
Posted Image

Yeah, I don't have a stereo at the moment. I just use my PDA as my in car music and video machine. Still working on putting the 6" speakers in the doors... so I don't have any sound yet. But I do have gauges!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users