Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

How do i remove the MPFI Intake?


  • Please log in to reply
3 replies to this topic

#1 ausubaru92

ausubaru92

    Turbo Talker

  • Members
  • 583 posts
  • Bowraville NSW Australia

Posted 23 April 2006 - 04:13 AM

I have a motor that i bought. the guy before me tried to remove the intake and he broke 2 of the bolts. Now that i have it, i cant remove the intake.

There are only 6 bolts right?

Any suggestions welcome
Thanks in advance

Gannon

#2 manxsta

manxsta

    USMB Regular

  • Members
  • PipPipPip
  • 119 posts
  • Adelaide S.A AUSTRALIA

Posted 23 April 2006 - 04:38 AM

Hi , basically the only way your will have any chance of removing it is to pump the bolts and holes full of wd 40 or penetrating oil , let it soak and then pry it up with a lever between the intake and the engine(with care but you will need to use some force to start it moving....once it moves up a little,use more wd..and send it back down to the head..and repaet this until it eventually comes free..heat may be of some help alternativly..but i would opt against this method,patience will be your key..corrosion sucks..cheers

#3 85Sub4WD

85Sub4WD

    EA82 Junkie

  • Members
  • 1,244 posts
  • Raleigh NC/Charlotte NC

Posted 23 April 2006 - 12:49 PM

did you disconnect the EGR tube (stupid question) - that will hold you up if you didnt - after that - prybar & WD-40 to the rescue

#4 ausubaru92

ausubaru92

    Turbo Talker

  • Members
  • 583 posts
  • Bowraville NSW Australia

Posted 24 April 2006 - 02:19 AM

There is no such thing as a stupid question,.. but yes i did remove the EGR.

As far as penetrating fluid goes, ive been told to find an alternative to wd40,.. PB Blaster? INOX? any others


Thanks Guys


Gannon




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users