Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

95 Legacy tranny problem,please help


  • Please log in to reply
2 replies to this topic

#1 DriftNlegacy

DriftNlegacy

    User Awaiting Email Confirmation

  • Members
  • PipPip
  • 16 posts
  • New Orleans

Posted 29 April 2006 - 04:07 AM

First of all i did a search and i found nothing,which i found odd because i was told my problem is commen.I just need to know how to fix it.

When i start my car and its about 75 degrees or below outside the tranny gets stuck in Park and wont let me shift out of gear. One morning it took about 15 minutes before i could leave my house because i could not get it out of Park.Does anyone know how to fix this or atleast whats wrong with the tranny?Any helpful info would be great,thanks.
Richard

P.S. I have a 95 Legacy Ls sedan automatic

#2 lmdew

lmdew

    _______

  • Members
  • 3,158 posts
  • Colorado Springs

Posted 29 April 2006 - 06:09 AM

Is it the shift lever?

If its the lever, there is a solenoid that should release the lock when you step on the brakes. There is a manual release, pry off the black trim ring around the shifter.

You will see a 1/4" hole in the shifter body, just push down with a round bar of some sort and it will release the shifter.

If its your shift lock soleniod, and you want a new shifter I have one you can have for $15+shipping.

If the shift lever is fine, the cable should be checked and fluid changed. It could be either. Is your AT Temp light flashing 16 times when you start the car? If so you have a trouble code stored and need to get it read.

#3 nipper

nipper

    Semi Elite Master of the

  • Members
  • 17,701 posts
  • Long Island NY

Posted 29 April 2006 - 12:50 PM

First of all i did a search and i found nothing,which i found odd because i was told my problem is commen.I just need to know how to fix it.

When i start my car and its about 75 degrees or below outside the tranny gets stuck in Park and wont let me shift out of gear. One morning it took about 15 minutes before i could leave my house because i could not get it out of Park.Does anyone know how to fix this or atleast whats wrong with the tranny?Any helpful info would be great,thanks.
Richard

P.S. I have a 95 Legacy Ls sedan automatic


Do this, put your foot on the brake pedal, then press in the release button. You should hear a relay click. if it does not you have a bad relay. If it does click and you cant get it out of park, then you have a bad solenoid.


nipper




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users