Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

weird electrical problems help!! 00 impreza outback sport


  • Please log in to reply
3 replies to this topic

#1 pos-subagoo

pos-subagoo

    New User

  • Members
  • Pip
  • 6 posts
  • Boston

Posted 09 May 2006 - 02:30 PM

I have a 2000 impreza outback sport and recently when i hit the brakes the instrument cluster lights up and when i let go of the brake it shuts off, also the display on the radio always stays on when the car is off there is nothing displayed on the radio,its just lit up. Any ideas? thank you very much in advance.


Mike

#2 nipper

nipper

    Semi Elite Master of the

  • Members
  • 17,542 posts
  • Long Island NY

Posted 09 May 2006 - 03:56 PM

For the dash light, check the rear brake sockets. Also have somone look at your front parking lights, they may be coming on too. I dont remember if the imprezza has a seperate turn signal light or not. Check the rear bulbs, and sockets. You are getting a backfeed through the brake somehow circuit somehow.. Remove the bulbs and see if it goes away Then replace one bulb and see what happens.

The radio, check the pins and see if its a short in the radio or the harness. There is a constant power feed to the radio so you have a memory. There could be a crossed wire there.

nipper

#3 cookie

cookie

    Elite Master of the Subaru

  • Members
  • 3,058 posts
  • SFO

Posted 09 May 2006 - 04:08 PM

I'd also wonder how the grounds for the brakelights are and if there has been a trailer on the car with those clip on wire things.

#4 pos-subagoo

pos-subagoo

    New User

  • Members
  • Pip
  • 6 posts
  • Boston

Posted 11 May 2006 - 09:57 AM

thank you for your responses, i will try those suggestions.if anyone has anymore please let me know

thanks again




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users