Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

90 Legacy heater issues ?


  • Please log in to reply
6 replies to this topic

#1 oregonloyale

oregonloyale

    User Awaiting Email Confirmation

  • Members
  • 255 posts
  • salem

Posted 15 May 2006 - 10:05 AM

I have this 90 Subie Legacy LS sedan auto that has intermittent heater blower usage.
Sometimes, but not most times it works fine.
The little green lites lite up when I push the frt defrost button or any for that matter and turn the fan on .
But most of the time nothin works.
I have checked the fuses and they are good - at least Im pretty sure I checked the right fuses.

#2 Cougar

Cougar

    Elite Master of the Subaru

  • Members
  • 6,424 posts
  • Anchorage

Posted 15 May 2006 - 10:51 AM

If the blower doesn't work on high speed then the motor is most likely going to need to be replaced or the relay is intermittent. You can check to make sure that voltage is getting to the motor connections when the trouble is happening to verify that it is the motor at fault. If the motor is ok then the problem may be due to a faulty blower relay.

#3 oregonloyale

oregonloyale

    User Awaiting Email Confirmation

  • Members
  • 255 posts
  • salem

Posted 15 May 2006 - 11:48 AM

Thanx for the info.
The fan works on all settings , just doesnt work all the time.
Its like 2 out of 10 times itll work , aswell as the lights on the controls that indicate which setting it is in.
i.e. - defrost , floor , a/c
What fuse it connected to this part of the panel?
And is there a relay for that ?

#4 Cougar

Cougar

    Elite Master of the Subaru

  • Members
  • 6,424 posts
  • Anchorage

Posted 15 May 2006 - 12:12 PM

The problem is most likely due to a faulty relay and tapping it while the problem is occuring may get the motor going to prove that. Look for the relay under the dash on the left side. There are other relays their also. The blower relay has a neutral color connector going to it. The fuel pump relay has a green connector, ignition is brown, and sun roof is red.

The power to the blower through the relay is from fuse 21 and the control is through fuse 15.

#5 blackbart

blackbart

    tlegacy driver

  • Members
  • 449 posts
  • Northeast PA

Posted 15 May 2006 - 06:31 PM

If it is the relay I have a few and can send you one for the cost of postage and a cup of coffee.......

#6 oregonloyale

oregonloyale

    User Awaiting Email Confirmation

  • Members
  • 255 posts
  • salem

Posted 16 May 2006 - 09:44 AM

Thanx mr blackbart.
Ill get back to you on that.
I still need to investigate.

#7 bepa

bepa

    USMB Regular

  • Members
  • PipPipPip
  • 86 posts
  • new york city

Posted 18 May 2006 - 06:36 AM

If it is the relay I have a few and can send you one for the cost of postage and a cup of coffee.......

hey blackbart we are going to have to meet one day. I see you bid on a lot of legacy's. I'll just getting back into a subaru. newly single with son in marines. what a test life is. hey what is the chance.

do you have a lsd 3.90- for a turbo SS. just put a used tranny in. had 61k miles on it. oh and do you have any mud flaps for the passenger side rear. have to get at you tomorrow. finishing up with watch. one day down the road I would like to switch over to a stick, just not yet.

I work in the city (new york) and live upstate in elizaville, that's near hudson new york. I enjoy weekend drives to new places and enjoy meeting new people. one other thing I've owned four subaru now, they are one of the best for taking a beating and keep on ticking.

what kind of seats fit the 91 legacy if you know? are wrx seats bolt in replacements?

be well and enjoy your weekend. daniel.barry@med.va.gov




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users