Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Howdy, All


  • Please log in to reply
6 replies to this topic

#1 RubyBlueSubie

RubyBlueSubie

    New User

  • Members
  • Pip
  • 8 posts
  • Oregon

Posted 28 October 2003 - 09:37 PM

Thanks for being here. My Subie is a '96 Legacy, 4D, with almost everything. (Not the Traction option). She drives like a dream, and I love her. However, while the sunroof flips up alright, I can only get the retraction to "catch" every once in a while. Reminds me of a dying cylinoid (sp?) on my old Volksy. Anyway, my neighbor advised that it probably isn't the motor, as the dealership suggested, but the cables, which he replaced in his (non-Subaru) car for about a hundred bucks. So, local dealer said no go - had to buy a whole new unit for around SIX HUNDRED bucks! Rats. Any other solutions? I can't do a new one.

Thanks for any help.

#2 SuperRallyRoo

SuperRallyRoo

    Defundit.com

  • Members
  • 1,430 posts
  • Tacoma, Wa.

Posted 28 October 2003 - 10:01 PM

U could always not open it... Is it all lubed up and stuff? This is in the totally wrong forum too... It should be in newer gen.

#3 Qman

Qman

    Happiness is... no lag!!

  • Moderator
  • 11,119 posts
  • Sumner

Posted 28 October 2003 - 11:33 PM

It may be the drive gear. Which may or may not be servicable. Where in Oregon are you? There are a couple of independent service shops in Oregon that you could go to and trust!

#4 Hondasucks

Hondasucks

    Subaru Technician

  • Members
  • 4,760 posts
  • Vancouver, WA

Posted 28 October 2003 - 11:36 PM

My 91 had issues, turned out it was a combination of a bad sunroof control unit (Junkyard time!) and a bad sunroof switch panel thinger, Replaced both of those and it worked just fine. Man I wish my 87 Turbowagon had a sunroof....

#5 RubyBlueSubie

RubyBlueSubie

    New User

  • Members
  • Pip
  • 8 posts
  • Oregon

Posted 29 October 2003 - 02:29 PM

Thanks all. (BTW, I thought this WAS the New Generation of Subarus. My apologies.) It used to work fine. Then, one day, it didn't want to retract. I opened and closed the flipper, and released the switch just before it closed tight, and tried the retracting switch again. Doing this several times, the retractor finally opened. It now takes longer to "find" that "spot" where the retractor finally opens.

Yes, I've lubed (with Tri-Flow, a silicon based lubricant) and WD-40 too. It doesn't appear to be "stuck," it just can't find that one spot that brings the flipper all the way down and then retracts back.

I will look into the control thing (junk yard time) and the switch as well. I'm on the Central Oregon Coast. Newport, Lincoln City area.

Thanks, and

#6 edrach

edrach

    RIP 6/28/14

  • Members
  • 12,326 posts
  • Bothell, WA

Posted 29 October 2003 - 08:49 PM

I had the same problem with mine and found one of the screws holding the rail had come partially out and caused it to hang up there. I didn't see it at first since it was under part of the mechanism. Try to catch up with some of the Oregon crowd (lots of them near Portland) if you can; they're mostly pretty handy and might be able to fix that without all that expense. I could suggest Richierich or his dad's shop for a more "honest" apprasial and repair.

#7 RubyBlueSubie

RubyBlueSubie

    New User

  • Members
  • Pip
  • 8 posts
  • Oregon

Posted 29 October 2003 - 09:31 PM

:clap: Ooooh, I hope so! Sometimes it's just the little things, eh?

I'll give it a go, wish luck.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users