Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

In-Dash CD Player Jammed ('04 Forester XT)


  • Please log in to reply
1 reply to this topic

#1 TampaSubaru

TampaSubaru

    New User

  • Members
  • Pip
  • 1 posts
  • Tampa, Fl

Posted 21 July 2006 - 09:13 PM

Anyone ever have their OEM in-dash CD player jam? I've got a 2004 Forester XT with the in-dash 6 CD changer with weather band. I put a CD in the other day and the unit automatically swithced to FM mode. Now, when I press the CD button, nothing happens. If I hold down the eject button long enough, the unit diplays "ALL CD EJECT," then switches back to FM mode again. None of the CDs eject.

Any tips? I'll probably try to pull the unit out tomorrow. I'm hoping it has a manual eject similar to a computer CD-rom. I anticipate I'll have to pick up a used or aftermarket stereo somewhere to replace it.

Thanks,
Dan

#2 Smpol19

Smpol19

    USMB is life!

  • Members
  • 215 posts
  • Nothern, VA / Long Island

Posted 22 July 2006 - 10:05 AM

I had something similar happen with the single disk CD player on my Impreza. I took it out, took it compleatly apart, cleaned everything with air, put it back together, has worked ever since. Maybe I just got lucky but its worth a try before buying a new one.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users