Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Power Steering Difficulties


  • Please log in to reply
1 reply to this topic

#1 mikeshoup

mikeshoup

    Ignorant

  • Members
  • 2,190 posts
  • City and County of Denver

Posted 28 July 2006 - 05:16 PM

So, I mostly started noticing this since I bought the wagon. Maybe its the XT rebelling against me.

The XT's steering wheel is a bit difficult to turn. Its still very turnable, but some days its even really difficult. I also notice a whine coming from it so often.

Is this a sign my P/S pump is going out? Fluid is topped off and normal.

If the P/S pump is going out, does one off of any other DL/GL/GL-10/Loyale work (provided I change the pulley)?

#2 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,661 posts
  • Roatán, Honduras.

Posted 29 July 2006 - 02:23 AM

Maybe the EA82 P/S Pump will Work, but I Suggest First to Change the Entire Power Steerin´ Fluid with the Better one you can Obtain, better if the new fluid got "Restoraton Additives" ...

It has worked fine for both my Wagons... Good Luck! :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users