Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

95 Impreza Mass Air Sensor Circuit Pbm.


  • Please log in to reply
1 reply to this topic

#1 AirheadDave

AirheadDave

    New User

  • Members
  • PipPip
  • 15 posts
  • Los Angeles

Posted 12 August 2006 - 12:50 AM

My 95 Impreza has been stalling for about 3 weeks. It usually happens in high outside heat, warmed up, after a short time shut off. When I start the car, everything is fine for between 10 sec and 10 minutes then the engine suddenly loses all power, and the RPM's stutter. It usually takes 3-5 seconds for the engine to die completely and there is a 50-70% chance that the engine will catch in that time and I can continue driving. If it stops, I can restart right away without a problem.

After 3 weeks the car finally threw a code: 100. Mass Air Flow Sensor Circuit fault.

Is there a history on these things I should know? Any place to start looking?

I haven't had time to check the wiring yet, but I thought that is where I'd start, hoping I can find a wear point or corroded connection.

Thanks in advance everyone.

Dave

#2 Manarius

Manarius

    1995 Subaru SVX LSi

  • Members
  • 1,609 posts
  • Grantham

Posted 12 August 2006 - 07:57 AM

I'd start by replacing the Mass Air Flow sensor itself. Find someone here who has one and is willing to sell it cheap (like 25 bucks). I had the exact same issues as you when my car's MAF sensor went bad.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users