Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Knock Sensor


  • Please log in to reply
2 replies to this topic

#1 briang@wybron.com

briang@wybron.com

    New User

  • Members
  • PipPip
  • 12 posts
  • Colorado Springs

Posted 29 September 2006 - 03:03 PM

I got the good ole CEC light, went to autozone and the code reads knock sensor. I can't seem to find the little bugger on my engine. Could someone give me a clue. 1998, 2.5 liter, Legacy Outback wagon.

Thanks

#2 jamal

jamal

    1000+ Super USER!

  • Members
  • 1,015 posts
  • Los Angeles

Posted 29 September 2006 - 03:38 PM

On top of the block pretty much right under the throttle body. Round sensor with a bolt through the middle. You'll need some crafty socket extension work to get it in/out.

#3 briang@wybron.com

briang@wybron.com

    New User

  • Members
  • PipPip
  • 12 posts
  • Colorado Springs

Posted 29 September 2006 - 03:44 PM

That's where I thought it was but I still I didn't see it there before. I will look again tonight. thanks




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users