Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Speedometer - Which part?


  • Please log in to reply
12 replies to this topic

#1 dssenne

dssenne

    USMB Regular

  • Members
  • PipPipPip
  • 61 posts
  • O'Fallon

Posted 26 October 2006 - 08:06 AM

Hi,
1st time poster here.
The speedometer on my wifes 92 Legacy 2WD wagon died yesterday (no warning, just died).
I disconnected the cable at the transmission (by removing the little wire clip, pulling out the inner cable - I didn't actually remove the whole end piece) and hooked it up to a cordless drill. The speedometer responded. What if anything does this tell me? Is the likely problem something in the end piece of the cable where it goes into the transmission?
BTW, I was able to slid this inner cable entirely out of its sheath, is this normal?
Does this mean that the actual speedomenter gauge / speed sensor is ok?
What should I look at replacing?
Also, if it means anything the cruise control is not working now either.
Thanks for any assisstance anyone can give me!
Dan

#2 seanski06

seanski06

    User Awaiting Email Confirmation

  • Members
  • 442 posts
  • carbon county

Posted 26 October 2006 - 08:56 AM

im not too intelligent...but if i was in your situation i'd go to a local junkyard grab a speedo cable and then put it in your car.....



but im sure someone else will help you from the board haha

just my .02

#3 lmdew

lmdew

    _______

  • Members
  • 2,830 posts
  • Colorado Springs

Posted 26 October 2006 - 11:42 AM

The drive may have failed in the trans. Check to see if the output is turning as the car is dirven. Plastic gears in some trans.

#4 dssenne

dssenne

    USMB Regular

  • Members
  • PipPipPip
  • 61 posts
  • O'Fallon

Posted 26 October 2006 - 11:58 AM

The drive may have failed in the trans. Check to see if the output is turning as the car is dirven. Plastic gears in some trans.


Would the plastic gears be the speedometer pinion?

#5 johnceggleston

johnceggleston

    Lite Master of the Subaru

  • Gold Subscribers
  • 6,315 posts
  • Virginia

Posted 26 October 2006 - 12:15 PM

Would the plastic gears be the speedometer pinion?


check out this pic. inside of front diff. yellow gear drives the speedo pinion(?), the hole above and to the right is the VSS#2 opening, or in your case , where the speedo cable enters the diff housing..

http://smg.photobuck...gAnch=imgAnch10

#6 Snowman

Snowman

    Midnight Passenger

  • Members
  • 3,538 posts
  • Haines

Posted 26 October 2006 - 12:45 PM

I just had a car where the little drive tang that acts as an intermediary between the cable itself and the drive assembly in the tranny had broken. Use a 17mm wrench to remove that plug-looking thing that the cable goes into on top of the tranny and see if that little piece is broken off inside there.

#7 dssenne

dssenne

    USMB Regular

  • Members
  • PipPipPip
  • 61 posts
  • O'Fallon

Posted 26 October 2006 - 02:32 PM

I just had a car where the little drive tang that acts as an intermediary between the cable itself and the drive assembly in the tranny had broken. Use a 17mm wrench to remove that plug-looking thing that the cable goes into on top of the tranny and see if that little piece is broken off inside there.


I removed the plug-looking thing, and inside there was a short piece of what looked like plastic tubing about 3/8" dia. and 3/8" long.
Below that was a rubber washer/grommet that was in pretty bad shape & below that a metal washer.
Below that is something that spins with a slot in the top (the pinion?)
that the end of the plug-looking thing fits into to turn the speedo cable.
However, I can't seem to get this thing(pinion?) to come out of the transmission. How is it held in?
I'm trying to pull it straight up and out with needlnose, but it's not coming.
BTW it spins freely in both directions.

#8 dssenne

dssenne

    USMB Regular

  • Members
  • PipPipPip
  • 61 posts
  • O'Fallon

Posted 26 October 2006 - 02:35 PM

I just had a car where the little drive tang that acts as an intermediary between the cable itself and the drive assembly in the tranny had broken. Use a 17mm wrench to remove that plug-looking thing that the cable goes into on top of the tranny and see if that little piece is broken off inside there.


Also, the drive tang you mention is VERY hard to turn, is that normal?

#9 lmdew

lmdew

    _______

  • Members
  • 2,830 posts
  • Colorado Springs

Posted 26 October 2006 - 04:02 PM

If the trans drive spins without moving the car, the gear is trash. You can not pull the shaft up, as it has a c-clip on the bottom.

You will need to pull the passenger side axle, the stub shaft, the bearing housing (make sure you mark it for proper bearing load) and then you can get in and change the gear/s.

Not an easy job, I'd get a new outter seal and the oring for the bearing housing. Make sure you do not cross thread it when you put it back in.

#10 dssenne

dssenne

    USMB Regular

  • Members
  • PipPipPip
  • 61 posts
  • O'Fallon

Posted 26 October 2006 - 07:29 PM

If the trans drive spins without moving the car, the gear is trash. You can not pull the shaft up, as it has a c-clip on the bottom.

You will need to pull the passenger side axle, the stub shaft, the bearing housing (make sure you mark it for proper bearing load) and then you can get in and change the gear/s.

Not an easy job, I'd get a new outter seal and the oring for the bearing housing. Make sure you do not cross thread it when you put it back in.

Thanks for the advice. Sounds like this is beyond my level of experience (struts,alt,etc.).
I was hoping this would be an easy fix, but.....oh well.
Thanks again everybody.

#11 ShawnW

ShawnW

    Subaru Master Technician

  • Administrator
  • 12,931 posts
  • Denver, Colorado

Posted 26 October 2006 - 07:59 PM

It may be more cost effective to drive with a GPS unit for your speedometer and you get a GPS as a bonus to the "repair".

Otherwise a used/rebuilt transmission is in order.

#12 dssenne

dssenne

    USMB Regular

  • Members
  • PipPipPip
  • 61 posts
  • O'Fallon

Posted 27 October 2006 - 08:04 AM

It may be more cost effective to drive with a GPS unit for your speedometer and you get a GPS as a bonus to the "repair".

Otherwise a used/rebuilt transmission is in order.


The car runs fine, do you think the transmission really needs to be replaced?
I thought it was more a case of it being difficult to get to the speedometer pinion that goes into the transmission. While I wouldn't feel comfortable tearing into it, couldn't my mechanic do it without having to replace the whole transmission?

I guess it boils down to how much he would charge vs the cost of a GPS unit.

#13 johnceggleston

johnceggleston

    Lite Master of the Subaru

  • Gold Subscribers
  • 6,315 posts
  • Virginia

Posted 27 October 2006 - 08:16 AM

the last time i asked , i was told , i think, that to remove and replace the trans was 3.5 hours. around here that equals about 275$. (i paid 515$, but he also changed the rear seal and oil seperator plate, new fulid , etc...) plus the time to open the case and make the repair, plus the parts. i don't know what gps cost.... do they give yopu your speed og travel?

The car runs fine, do you think the transmission really needs to be replaced?
I thought it was more a case of it being difficult to get to the speedometer pinion that goes into the transmission. While I wouldn't feel comfortable tearing into it, couldn't my mechanic do it without having to replace the whole transmission?

I guess it boils down to how much he would charge vs the cost of a GPS unit.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users