Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

How many EA82 P/S pumps are there? Which is this one?


  • Please log in to reply
11 replies to this topic

#1 moosens

moosens

    Psychotic Subathusiast

  • Members
  • 1,234 posts
  • Bridgeport CT

Posted 12 November 2006 - 12:11 PM

I have a lower profile pump that has a double pulley and accepts shorter hoses than the typical EA82 sedan/wagon pump.

Is this an XT pump?

I'll try to get some pictures later,if I have time.

One low profile pump needed that doesn't leak or make noise.
Thanks for any help.

#2 NorthWet

NorthWet

    Eeyore Incarnate

  • Members
  • 5,039 posts
  • Bremerton, WA

Posted 12 November 2006 - 02:14 PM

All of my non-XTs (85-90, na and T) have the same style PS pump. Reservoir directly over the pump, dual-pulley sheaves, same length inlet/outlets.

My 89 XT has a different pump, reservoir sits side-saddle to the pump (biased to passenger-side), so chassis lines are shorter. Standard XT pump is ribbed-belt.

#3 Bucky92

Bucky92

    Drive Fast, Take Chances

  • Members
  • 3,664 posts
  • New Milford

Posted 12 November 2006 - 02:24 PM

I have one around here somewhere..if its the right one ..come and get it...also dont forget..I have the Y pipe for the 78 wagon

#4 moosens

moosens

    Psychotic Subathusiast

  • Members
  • 1,234 posts
  • Bridgeport CT

Posted 12 November 2006 - 07:59 PM

I have one around here somewhere..if its the right one ..come and get it...also dont forget..I have the Y pipe for the 78 wagon



Dang'd if I wasn't just thinking about that Y-pipe.Gonna be needing that.The '78 has a new clutch cable and is now much more drivable.
Thanks Connie,I'll be in touch.I was thinking afterwards that Andrew could have brought that down....oh well


Yes,Pat the type I was forced to use is the side saddle reservoir.The lines weren't about to be removed,etc. at that point so it was easier to swap the pump.I didn't hear it making noise before,but I only drove the car for a very short time.

Looking at it today it seemed fairly dry,lever not bad,just still noisy when you crank the wheel.This pump may have had the pulley changed,or should I maybe be getting ribbed belts?I used the same belts it came to me with,regular old V belts.

#5 GeneralDisorder

GeneralDisorder

    Elite Master of the Subaru

  • Members
  • 20,280 posts
  • Portland

Posted 12 November 2006 - 08:05 PM

There's a few of them - there's the XT's ribbed belt style with the different reservior. There's the EA81T pump which is the same as early EA82, and there are two types of pulley mountings on the EA82's....

I would say there's probably 4 pumps... maybe a picture would help us ID it....

GD

#6 WoodsWagon

WoodsWagon

    Formerly 91Loyale

  • Members
  • 3,945 posts
  • NH

Posted 13 November 2006 - 01:25 PM

Ive seen the pump, the resavaur sits side-saddle on it, with a pipe that joins in the top with 2 10mm bolts.

In my experience, all the subaru pumps are the same, just some of them have slightly different size mounting bolts. I put an EA82 pump on my EJ22, all I had to do was clearance the holes in the bracket a bit.

Moosens: I'd swap the pully and resavaur over to the pump that was hanging out of the wagon we pulled the tranny out of, use a new rubber sealing thingy where the resavaur pipe bolts to the top of the pump.

#7 moosens

moosens

    Psychotic Subathusiast

  • Members
  • 1,234 posts
  • Bridgeport CT

Posted 13 November 2006 - 06:56 PM

I wonder if I can score a new rubber seal thingy.....

Only problem is,me and the car are in Bridgeport with no intentions of driving back to Charlie's too soon.

#8 Bucky92

Bucky92

    Drive Fast, Take Chances

  • Members
  • 3,664 posts
  • New Milford

Posted 13 November 2006 - 07:28 PM

I wonder if I can score a new rubber seal thingy.....

Only problem is,me and the car are in Bridgeport with no intentions of driving back to Charlie's too soon.


Like I said Pual..I have one here and you are more than welcome to it...maybe with some sweet talkin or something I can run it down or meet half way ..

OK Hockey Time

#9 WoodsWagon

WoodsWagon

    Formerly 91Loyale

  • Members
  • 3,945 posts
  • NH

Posted 14 November 2006 - 12:51 AM

Jack a pump out of any parts subaru you can find. Legacy's will work too. Someone should know what the real name for the "rubber sealing thingy" is. There's an O ring and a rubber cone seal dealy. If you replaced just that, it might fix it. The seal was leaking ATF out, but it's probably letting air in and making the pump moan.

#10 moosens

moosens

    Psychotic Subathusiast

  • Members
  • 1,234 posts
  • Bridgeport CT

Posted 14 November 2006 - 07:12 PM

Thanks guys.

I'll see about that seal first before anything else.

#11 NoahDL88

NoahDL88

    Elite Master of Cookies

  • Members
  • 4,264 posts
  • Everett, WA, USA

Posted 14 November 2006 - 07:16 PM

That XT motor you sold me had a ps pump on it, you want that i should send it back to you? the pump, not the engine.

#12 moosens

moosens

    Psychotic Subathusiast

  • Members
  • 1,234 posts
  • Bridgeport CT

Posted 15 November 2006 - 05:21 PM

That XT motor you sold me had a ps pump on it, you want that i should send it back to you? the pump, not the engine.




Well,Andrew is supposed to hook me up with it,but thanks.I'll keep that in mind just incase.



For all the effort on this car and it's $100 price I can't complain.Well,wait a minute.....where do I start.:lol:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users