Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

2005 Outback 2.5 XT Suspension / HATE IT


  • Please log in to reply
4 replies to this topic

#1 Wakeboarder-Jrod

Wakeboarder-Jrod

    New User

  • Members
  • Pip
  • 3 posts
  • Castro Valley

Posted 22 December 2006 - 10:42 AM

My wife drives an 05 2.5 Turbo with about 32K miles on it. Recently, it seems like the suspension went to hell. It's sloppy, loose, soft, etc. It feels like it's all over the road, swaying back and forth as I try to serve it! :headbang:

Also, at 25K miles, the inner and outer edges of the tires were bald. The alignment is good, and the tires were rotated regularly.

In hard corners, I can feel the inside front wheel chattering a little.

Bad struts maybe? Has anyone tried replacing the swaybars with something heavier?

I'm not expecting a sports car. But this thing handles like a Suburban! I would like it to drive a little more like its German competitors.

Help!

#2 ericem

ericem

    First Gen Legacy Master

  • Members
  • 2,477 posts
  • CANADA Maple,ON

Posted 22 December 2006 - 10:50 AM

I test drove one, and they feel really solid, not floaty, i feel like i could corner at 90mph:lol: This sounds like camber and strut, and sway bar issue, id bring it to the dealer, things definitly don't sound right, and make sure all 4 tires are inflated properly.

#3 Wakeboarder-Jrod

Wakeboarder-Jrod

    New User

  • Members
  • Pip
  • 3 posts
  • Castro Valley

Posted 22 December 2006 - 10:52 AM

Just put new tires on it yesterday....same thing.

The car started out solid. 3 or 4 people + gear makes the problem even worse.

#4 firstwagon

firstwagon

    Eat, Live, Breath Subaru

  • Members
  • 255 posts
  • British Columbia

Posted 22 December 2006 - 12:48 PM

It should be under warrantee still. Take it to the dealer and explain the problem.

I'll bet you have broken component or missing bushing.

#5 nipper

nipper

    Semi Elite Master of the

  • Members
  • 17,633 posts
  • Long Island NY

Posted 23 December 2006 - 12:09 AM

My money is on a broken sway bar connection or broken sway bar. Its not common but it happens.


nipper




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users