Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

- - - - -

2001 Subaru Legacy GT Help


  • Please log in to reply
1 reply to this topic

#1 Guest_evilmidget76_*

Guest_evilmidget76_*
  • Guests

Posted 30 July 2003 - 10:21 AM

I have a 2001 Legacy. After my 60k warranty expired I soon got a vibration noise during acceleration above 3k rpm's. It seems to be coming from the right side. I checked under and over in the engine compartment and can't seem to find anything. It sounds like a hollow vibration. If anybody has some clues I would appreciate it. Thanks!

#2 Guest_intrigueing_*

Guest_intrigueing_*
  • Guests

Posted 31 July 2003 - 08:22 AM

Check the heat shields on your exhaust.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users