Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

info about stainless steel brake lines


  • Please log in to reply
1 reply to this topic

#1 mellow65

mellow65

    Subaru, my drug of choice

  • Members
  • 1,084 posts
  • Portland

Posted 21 January 2007 - 05:45 PM

So im looking to put some stainless steel brake lines on my legacy and was curious if any one had any brands they could recommend over the others. I bought some ebay ones awhile back for another car. I never had any problems with them but many people did. I guess the line would break and the fluid would make a bubble in the plastic coating. Needless to say it wasn't a pretty thing. Thank god i never had that happen to me.

#2 Commuter

Commuter

    Subaru Master

  • Members
  • 1,857 posts
  • Niagara area, Ont Canada

Posted 21 January 2007 - 06:05 PM

I put some TechnaFit (I think that's the spelling) on mine about 5 years ago. I've never had any problem.

Commuter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users