Jump to content

Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse

- - - - -

90 Legacy - vent/heat/ac/defrost buttons stick

  • Please log in to reply
6 replies to this topic

#1 Guest_pelagic30_*

  • Guests

Posted 28 July 2003 - 06:12 AM

I thought this problem would be more common, since I have two legacy's and they both have the same problem, but I did a search and found nothing.

Anyone else have a problem with their air system buttons not working ? I assume that they are vacuum controlled and either worn out or dirty mechanisms, has anyone fixed these ? What did it take to fix ?


#2 Guest_Legacy777_*

  • Guests

Posted 28 July 2003 - 06:28 AM

what do you mean buttons stick. Are the buttons physically sticking, or is nothing happening/changing when you press the buttons?

It is a common thing on some higher mileage first gen legacies. Mine does it sporadically. A button pushing dance will usually fix it for a while. The vents are operated by a motor. whether that motor supplies vacuum or uses electric.....I'm not 100% sure. I've been meaning to get under there and see what's going on. I believe it's an electrical issue, but not sure exactly what or where.

#3 Guest_97svx_*

  • Guests

Posted 28 July 2003 - 08:19 AM

My 95 Legacy had sticky buttons from coffee being spilled on them. Pushing one button in would not cause the previous button from popping out. Had to take the assembly out, washed it out with water, replaced the illumination bulbs, and it worked fine after that.


#4 Guest_Setright_*

  • Guests

Posted 28 July 2003 - 12:41 PM

My 1990 does not use vacuum. There is a mechanical arm that is moved by a motor.

Taking off/out the glovebox should give you access to it.

#5 Guest_GBianchi_*

  • Guests

Posted 28 July 2003 - 03:26 PM

The control is electric, mine stops working at times and a good thump on the dash gets to respond, not a technical fix but it works:p

#6 Guest_pelagic30_*

  • Guests

Posted 29 July 2003 - 04:23 AM

I like that fix... thump on the dash. Thanks for the advice.

The twins will be easier to live with if this is fixed.

90 Legacy L 2WD
90 Legacy L AWD

#7 Guest_EOppegaard_*

  • Guests

Posted 29 July 2003 - 11:00 AM

I had this problem on my 93 wagon, I ended up spraying electrical contact cleaner in-between all of the buttons, and then just worked it in by hitting all the buttons.

However the thud may work just as good :-)

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users