Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 2 votes

EA82 Dashboard BackLights Upgrade to H.I.D. White L.E.D.´s

Instrument Cluster Dashboard Loyale 2.7 Turbo Dash LED LEDs Retrofitting JesZeK

  • Please log in to reply
142 replies to this topic

#51 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 06 September 2012 - 09:16 PM

This is How the Instrument Cluster ended up,

after the Deep Cleansing and New LED Bulbs Retrofit, just Before to put it Back in my BumbleBeast:


Posted Image


Posted Image



#52 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 06 September 2012 - 09:24 PM

To put Back the Four Vacuum Hoses for the A/C Control Buttons is Easy, because Subaru Marked each one with Numbers... #1, #2 and #4 ...No Number three! ... :D ... but the last one is unmarked, as the last Vacuum Plug, so No problem at all...


Posted Image



...the Problem is to Keep them in Place, because with Age, those becomes Loose and the Tiny metallic plate that goes in their back, attached to the side's screws, isn't enough to keep 'em Hooked. So, I Used four tiny Zip ties, one for each hose and cutted their excess longitude with a scissors:


Posted Image



That shall be More than enough ... ;) ...

Edited by Loyale 2.7 Turbo, 06 September 2012 - 09:26 PM.


#53 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 06 September 2012 - 09:31 PM

Finally, this are the Results:


Posted Image


Posted Image


Posted Image


Posted Image



#54 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 06 September 2012 - 09:36 PM

As I wrote:

► You can see that the only part that has Green Tint painted on the instrument Cluster, is the Kilometers per Hour numbers, under the Miles per Hour numbers.

► I managed to Fix the Oil Pressure Gauge, just by sliding it slowly with my Finger, 'till it reached the Real "Top" of the readings, then it sat on the right 0 Mark, not under it as it was.

The Dimmer does work Fine with LED Bulbs. :D

Let me Know what do you think about this Mod...

Kind Regards.

Edited by Loyale 2.7 Turbo, 06 September 2012 - 09:58 PM.
Misspelled Word...


#55 Crazyeights

Crazyeights

    SubaRube Goldberg

  • Gold Subscribers
  • 934 posts
  • PNW

Posted 07 September 2012 - 08:45 AM

Very nice!

Thank you for the write up

#56 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 07 September 2012 - 12:22 PM

You're Welcome! ... and you gave me an Idea: I'll post this Ideas on the USRM, because the Threads in the Forums tends to fade away with time, but there this ideas could help more people.

Kind Regards.


#57 Dee2

Dee2

    USMB Regular

  • Members
  • 254 posts
  • US

Posted 07 September 2012 - 02:03 PM

Really enjoyed reading this thread. Nicely documented. Thanks for making the extra effort to keep us appraised of the whole job and including the photos.

It looks great! :headbang:

I had the same problem with my oil pressure gauge and solved it the same as you did. Unfortunately, I have noticed that with mine, now, the readings always seem to be a bit low.

Still, it is better than the negative readings I was getting.

#58 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 07 September 2012 - 03:13 PM

Really enjoyed reading this thread. Nicely documented. Thanks for making the extra effort to keep us appraised of the whole job and including the photos.

It looks great! ...


Thank you for your Kind Words. :)


... I had the same problem with my oil pressure gauge and solved it the same as you did. Unfortunately, I have noticed that with mine, now, the readings always seem to be a bit low...


Yes, Same here... I Believe that the Moment the Sender's cable did the Short Circuit that risen the Needle too much, something got stretched within the marker's resistance and then its readings are too low.

But I Agree that is Better to see the Gauge Low than to see
"Negative" Readings.

Kind Regards.


#59 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 07 September 2012 - 11:39 PM

Somehow I Believe that the Original Designers of this Instrument Cluster, desired that it looked with Great Contrast, white numbers over black background... but since the incandescent bulbs emit amber Light, they decided to paint the Numbers with a green tint, that the Newer clusters has.

The White illumination gives to the car a Much Modern Feeling, and is not Blinding at all, but Camera Lens tend to exagerate the Glow... also I can reduce the Brightness using the Dimmer control.

Edited by Loyale 2.7 Turbo, 07 September 2012 - 11:50 PM.
Misspelled Word, Fixed.


#60 nipper

nipper

    Semi Elite Master of the

  • Members
  • 17,594 posts
  • Long Island NY

Posted 07 September 2012 - 11:42 PM

This would solve my lighting issue in the Justy.

#61 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 07 September 2012 - 11:48 PM

I Uploaded a Video and is in HD ;)

You can reach it,
~► Here.

Let me Know what do you think about the LED instrument Cluster.

Kind Regards.


#62 one eye

one eye

    I'm A Subaholic

  • Members
  • 2,572 posts
  • Mt.Vernon Washington

Posted 08 September 2012 - 11:15 AM

That looks pretty sweet, nice the way you have everything marked and setup in your thread too!!!! I think this would be cool to do on my touring wagon....

Jeff

#63 kanurys

kanurys

    High Altitude GL

  • Members
  • 690 posts
  • Durango, CO

Posted 10 September 2012 - 02:09 PM

Looks great. The white light refreshes those old gauges. I saw your oil pressure at 4000 rpm. Classic EA82 engine and gauge reading.

#64 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 10 September 2012 - 02:21 PM

Thank you Kanurys and one eye, for you Kind Words. :)

Yes, the White LEDs refreshes those old gauges and also renews the Old interior look -at night times- of these old Subies, now the Dashboard does look "Modern" somehow.

Kind Regards.

Edited by Loyale 2.7 Turbo, 10 September 2012 - 02:24 PM.


#65 ontherun987

ontherun987

    USMB Regular

  • Members
  • 134 posts
  • spanaway wa

Posted 10 September 2012 - 04:18 PM

Looks great:headbang:, Did you need the replacement sockets?

Would these leds work
http://www.amazon.co...00U&tag=ywis-20
http://www.amazon.co...WCS&tag=ywis-20

Edited by ontherun987, 10 September 2012 - 04:22 PM.


#66 tractor pole

tractor pole

    [catch phrase here]

  • Members
  • 548 posts
  • Monroe, WA

Posted 10 September 2012 - 06:39 PM

WOW very nice!

I will probably end up doing this while my car is down for an EJ swap:headbang:

Ben

#67 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 10 September 2012 - 10:00 PM

WOW very nice! ...


Thank You!

I'm Glad to know that my Ideas will Help other People to Improve their Subies.
;)


Looks great :headbang:, Did you need the replacement sockets? ...


No, I used the Original ones, by the way, those are "Toshiba" with their original "Toshiba" Bulbs, also the new ones has the same Brand.

About the LED Bulbs I used, let me Share some info and Links:


#68 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 10 September 2012 - 10:04 PM

- The T-10 ones are These: ~► Here.

Those are Perfect fit to the Sockets and the Instrument Cluster.

#69 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 10 September 2012 - 10:14 PM

- The T-5 ones are These: ~► Here.

Those are Perfect fit to the Sockets, the Instrument Cluster and the Upper Left and Right Buttons.

Also the Lower Red Stripes with Rectangular Warnings, such as "Oil", "Brake Lamp" , etc...


#70 92_rugby_subie

92_rugby_subie

    Subaru Master

  • Members
  • 1,990 posts
  • Hillsboro OR

Posted 10 September 2012 - 10:18 PM

Thanks! I wonder, I dont see a red or a blue alternative...

Would the like stained glass paint work? or do you think itd make the bulbs dim and not be any better than what Ive got now?

#71 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 10 September 2012 - 10:18 PM

But there are two T-5 bulbs needed in the Dashboard, one for the "Lights" Button on the Left, and another one for the "Fan Speed" Button on the Right (Early EA82 Models) and that kind of Multiple LEDs T-5 bulb does a Short Circuit with the Surrounding metal ring, somehow...

So I Used a couple of Single LED T-5 Bulbs there, with inverted Tip, because those are all Plastic, like the ones pictured Below:



Posted Image



#72 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 10 September 2012 - 10:21 PM

Thanks! I wonder, I dont see a red or a blue alternative...

Would the like stained glass paint work? or do you think itd make the bulbs dim and not be any better than what Ive got now?



I Choosed White, However, there are more Colours to Choose, but Remember that only the Early EA82's clusters doesn't have the Green Tint painted, so in Green Clusters, other Colours than White and Green, should fight that green Tint with unpredictable results, but will Not look Not any Dim like the Standard incandescent Bulbs your Cluster already has.

Kind Regards.


#73 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 10 September 2012 - 10:27 PM

The problem with the Single LED T-5 Bulbs is that their plastic base is So Fat, that the Socket does Expand and don't pass thru the Dashboard's Hole...

I had to Press and somehow "Squeeze" those LED's Plastic Base with a Pincers, in order to "Slim" them a Little, 'till I get them in.
:D

#74 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,732 posts
  • Roatán, Honduras.

Posted 10 September 2012 - 10:38 PM

There is a Thread in NASIOC about how to remove the Tint from the Instrument Cluster with Sandpaper, on a Subaru Impreza, Maybe that Ideas could Apply to the Subaru Loyale Green Tint's instrument Cluster.

Look Here:
~► http://forums.nasioc...ad.php?t=690378

Kind Regards.

#75 92_rugby_subie

92_rugby_subie

    Subaru Master

  • Members
  • 1,990 posts
  • Hillsboro OR

Posted 10 September 2012 - 11:03 PM

So whats your final bulb tally to replace all the bulbs?

I might as well replace all mine...

86 GL so I dont think I have the green tint...?





Also tagged with one or more of these keywords: Instrument, Cluster, Dashboard, Loyale 2.7 Turbo, Dash, LED, LEDs, Retrofitting, JesZeK

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users