Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Coolant temp sensor..EA82


  • Please log in to reply
9 replies to this topic

#1 tidd1340

tidd1340

    USMB is life!

  • Members
  • 139 posts
  • Buffalo,N.Y.

Posted 16 May 2007 - 09:53 PM

Mine is shot. I went with autopartsgiant. c om..said they had it..that was 4/22/07..i just filed a chargeback on my c/c as i have no part or refund,or any answers on where it is..anyone have a source for one of these? Or have a used one? The local stores want 99.00..hoped i could get one cheaper.

#2 rllywgn

rllywgn

    Diff Lock Dynamite!

  • Members
  • 381 posts
  • Vegas Baby

Posted 17 May 2007 - 12:51 AM

try the junkyards if available.. most of them have two temp sensors.. which one do you need? t-stat housing or block?

#3 tidd1340

tidd1340

    USMB is life!

  • Members
  • 139 posts
  • Buffalo,N.Y.

Posted 17 May 2007 - 05:43 AM

t-stat one..2 wires w/green plug. Older subies in NY are hard to find in the yards..they just rust away....

#4 daeron

daeron

    Cunning Linguist

  • Members
  • 3,600 posts
  • West Palm Beach

Posted 17 May 2007 - 05:48 AM

you sure its not just a wiring problem? the wires, or the terminals, go bad far more often than the sensors themselves. Rust is the main culprit of "bad," that is why I ask.

#5 SmashedGlass

SmashedGlass

    Eat, Live, Breath Subaru

  • Members
  • 661 posts
  • From CO, stuck in FL

Posted 17 May 2007 - 01:30 PM

Mine is shot. I went with autopartsgiant. c om..said they had it..that was 4/22/07..i just filed a chargeback on my c/c as i have no part or refund,or any answers on where it is..anyone have a source for one of these? Or have a used one? The local stores want 99.00..hoped i could get one cheaper.


wtf?? i think i paid about $15 for my sensor @ Checkers.....weird, man.

#6 Gloyale

Gloyale

    It's a sickness

  • Members
  • 8,894 posts
  • Corvallis, OR PNW

Posted 17 May 2007 - 02:08 PM

wtf?? i think i paid about $15 for my sensor @ Checkers.....weird, man.


MPFI uses a much more common style of sensor, connector plugs directly to it and there are no pigtails. The SPFI one has those wires and a connector. I believe you COULD use the MPFI one if you change the connector because they output in the same range. I am not sure if they have the same threads however.

#7 SubaRube

SubaRube

    Eat, Live, Breath Subaru

  • Members
  • 256 posts
  • San Leandro, CA

Posted 17 May 2007 - 02:58 PM

I've been running an MPFI one in my SPFI for a year or so.
No problems so far.

For Comparison -
http://www.partsamer...ype=290&PTSet=A
MPFI

http://www.partsamer...ype=290&PTSet=A
SPFI ('88-'94)

http://www.partsamer...ype=756&PTSet=A
SPFI ('86-'87 only -referred to as an "Air Charge Tempeperature Sensor")

For some reason they charge almost double for the '88-'94 SPFI version than the '86-'87 version of essentially the same part, just with a diff. connector. Weird.

Edit - I fixed all the links - should work now

#8 tidd1340

tidd1340

    USMB is life!

  • Members
  • 139 posts
  • Buffalo,N.Y.

Posted 17 May 2007 - 04:25 PM

Subarube,can you post a p/n on the cheaper one? When i click the links i get just the expensive ones..thanks!!

#9 Gloyale

Gloyale

    It's a sickness

  • Members
  • 8,894 posts
  • Corvallis, OR PNW

Posted 17 May 2007 - 04:26 PM

COOL!!! sticky this or submit the change over process to the USRM.

#10 daeron

daeron

    Cunning Linguist

  • Members
  • 3,600 posts
  • West Palm Beach

Posted 17 May 2007 - 06:01 PM

its up to one of us to submit it to the USRM.

I just submitted Bucky92's photo of the fuse panel cover.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users