Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

99 OB intermitent speedo


  • Please log in to reply
5 replies to this topic

#1 billyfrank

billyfrank

    New User

  • Members
  • PipPip
  • 14 posts
  • Central Coast, Ca

Posted 25 June 2007 - 10:55 AM

Hi there,
I have had an intermitent speedo problem for some time. It comes on and off at random and I can't see any type of pattern to it. The cruise control still works so I know the car is registering speed somewhere.
Any idea's? I know there is a couple of different sensors and am trying to narrow it down. Don't want to pay the dealer.
Thanks,
Billy

#2 OB99W

OB99W

    Elite Master of the Subaru

  • Members
  • 3,315 posts
  • Ithaca

Posted 25 June 2007 - 01:25 PM

I used the search function and came up with these, which may help:
http://www.ultimatesubaru.org/forum/showthread.php?t=69733
http://www.ultimatesubaru.org/forum/showthread.php?t=65288
http://www.ultimatesubaru.org/forum/showthread.php?t=61106
http://www.ultimatesubaru.org/forum/showthread.php?t=55211

#3 lmdew

lmdew

    _______

  • Members
  • 3,053 posts
  • Colorado Springs

Posted 25 June 2007 - 01:48 PM

If the links don't fix it I have a good used one. Lmdew@hotmail.com

#4 billyfrank

billyfrank

    New User

  • Members
  • PipPip
  • 14 posts
  • Central Coast, Ca

Posted 25 June 2007 - 11:10 PM

Thanks guys.

OB99W-thanks for the search. I could not find that option(still having trouble), must be going blind.

Imdew-thanks I will get back to you on that soon as I might need one.

Billy

#5 OB99W

OB99W

    Elite Master of the Subaru

  • Members
  • 3,315 posts
  • Ithaca

Posted 26 June 2007 - 05:06 AM

Thanks guys.

OB99W-thanks for the search.

You're welcome.


I could not find that option(still having trouble), must be going blind.[...]

Your eyes are probably okay. Start here: http://www.ultimates...display.php?f=3 . Then look at the gray bar at the top of the list of threads. On the left it says "Threads in Forum : New Generation of Subarus"; on the right is "Search this Forum" -- click on that and it will open a box for the search. Note that it won't return anything if you don't enter at least four characters; if the term you're looking for has fewer, you need to add a "wildcard". For example, to search for "ATF", enter "ATF*".

#6 xrturbo

xrturbo

    Subaru Fanatic!

  • Members
  • 368 posts
  • allentown

Posted 26 June 2007 - 05:13 AM

99s have a way to common problem of the speedo head itself goes bad in the cluster. Most Subaru dealers actually stock that part. We have run into this before with a couple times this year. Anymore we just for go all the diagnostic with them anymore because we have seen it that much.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users