Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

4EAT transmission fluid color?


  • Please log in to reply
6 replies to this topic

#1 oregonloyale

oregonloyale

    User Awaiting Email Confirmation

  • Members
  • 255 posts
  • salem

Posted 11 December 2003 - 02:30 PM

I have been experiencing some intermittent problems with my legacy AWD tranny.
It was recently rebuilt by AAMC 4k miles ago and the other day the wife said she was @ a stop and when she tried to go forward the car didnt go and then ...... it did.
Also it will sometimes down shift hard into st when coming to a stop .
I pulled the dipstick and the fluid level is good , but the color of the fluid wasnt very red like Im used to seeing, it was kinda clearish with a ting of red.
Does Sube use a different trans fluid than other cars ?
And is the fluid a different color ?

#2 captainehh

captainehh

    USMB Regular

  • Members
  • PipPipPip
  • 31 posts
  • Eugene

Posted 11 December 2003 - 05:41 PM

To check the fluid make sure that you've driven the car for a good 10 or 15 miles to warm things up. Check the fluid with the engine running. It should read at the "Full-Hot" mark. Subies don't use special fluid. Dexron III is what you want. It should be red in color. Sounds to me like you need to top things off of are ready for a fluid/filter change.

#3 Suzam

Suzam

    1000+ Super USER!

  • Members
  • 1,193 posts
  • Wilmington, Delaware

Posted 11 December 2003 - 05:59 PM

I would hope that the warranty for the rebuild is more than 4k. Take it back to the shop and have them check it. You'd want ANY kind of problems documented in case of a failure before the warranty is up.

#4 oregonloyale

oregonloyale

    User Awaiting Email Confirmation

  • Members
  • 255 posts
  • salem

Posted 11 December 2003 - 06:07 PM

Yeah , Im gonna take it back to AAMCO anyways and have them at least replace the fluid .
Captainehh - Yes the car had been driven to the gas station and that is where I checked the fluid .
It was also a level place and the level of the fluid on the dipstick was perfect.
It was the actual color of the fluid I was concerned about , especially being as there is ONLY 4k on the transmission.The Warranty is 12mths 12k miles.

#5 Legacy777

Legacy777

    Moderator

  • Moderator
  • 12,604 posts
  • Houston, Tx

Posted 11 December 2003 - 06:20 PM

yes, take it back to aamco....

also, for future reference....don't take your car to aamco....they suck.

Try and find an independant trans shop.

What area of the country do you live in?

#6 oregonloyale

oregonloyale

    User Awaiting Email Confirmation

  • Members
  • 255 posts
  • salem

Posted 11 December 2003 - 06:23 PM

I live in Salem Oregon , NW.
I bought the car about 2 weeks ago and it came with a rebuilt Tranny from AAMCO, I even have the reciept.

#7 captainehh

captainehh

    USMB Regular

  • Members
  • PipPipPip
  • 31 posts
  • Eugene

Posted 11 December 2003 - 08:16 PM

I'm just down the road in Eugene. I've had a very positive experience with a tranny shop here in town that i'd be happy to reccommend. But yeah, I second the fact that AAMCO sucks-they're like getting your car painted at MAACO (sp?)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users