Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Clean cooling system....@120K miles


  • Please log in to reply
4 replies to this topic

#1 Setright

Setright

    Elite Master of the Subaru

  • Members
  • 3,176 posts
  • Denmark

Posted 20 December 2007 - 12:57 AM

Hi all!


It would appear that my drain/fill with demin water/drive/drain/fill ritual when chaning coolant has payed off. Just replaced the cambelt at 120K miles and along with it, the waterpump. The engine block was equally clean inside:

http://img.photobuck...mp_impeller.jpg


:) :) :)

#2 Setright

Setright

    Elite Master of the Subaru

  • Members
  • 3,176 posts
  • Denmark

Posted 21 December 2007 - 11:22 PM

So....no one thinks this is even slightly impressive?


Happy Holidays :)

#3 avk

avk

    My Outback is bigger than yours

  • Members
  • 959 posts
  • Somerset County, NJ

Posted 21 December 2007 - 11:48 PM

I hope the rust seen on the impeller wasn't there until the pump became exposed to the air.

#4 ericem

ericem

    First Gen Legacy Master

  • Members
  • 2,477 posts
  • CANADA Maple,ON

Posted 22 December 2007 - 12:41 AM

Amazing!! Would have been more amazing if I had done a waterpump before and seen how bad it can actually get. My fluid was never changed in 200,000+km. Someone else got the opportunity instead to see what the pump looked like :-p

#5 Setright

Setright

    Elite Master of the Subaru

  • Members
  • 3,176 posts
  • Denmark

Posted 22 December 2007 - 02:33 AM

avk...it was fine coming out, rust grew later ;)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users