Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Evans Creek run pics 1/09


  • Please log in to reply
6 replies to this topic

#1 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 18 January 2009 - 12:57 PM

A few of us down south were jonesing for mud/snow and seeing how Rieter was questionable, we decided to hit EC.
I had to stay on the main roads because once I aired down a front axle started making sounds of eminent failure:-\
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image

#2 4x4brat

4x4brat

    USMB Regular

  • Members
  • PipPipPip
  • 81 posts
  • sacramento

Posted 18 January 2009 - 01:22 PM

:slobber::slobber::slobber::slobber:Awhsumm:slobber::slobber::slobber:

#3 bratman18

bratman18

    ADIDASubarus

  • Members
  • 3,429 posts
  • Jefferson, Maine

Posted 18 January 2009 - 04:20 PM

Again I'm so jealous! The view is amazing!! And I love the hatch!

#4 jbbvw

jbbvw

    USMB is life!

  • Members
  • 186 posts
  • Tacoma

Posted 19 January 2009 - 11:59 PM

Forgot my camera, but here's some cell pics from Evans Creek.
Had a little trouble getting up this hill, but not bad.
Posted Image Posted Image Posted Image
Great veiw up top. The sun was very hot!
Posted Image Posted Image Posted Image
Coming back down was the hard part. The road had about 3 feet of wet snow. We spent about 3 hours digging, pulling and winching out the many times we got stuck in it. This pic is after digging.
Posted Image
Finally on the way home.
Posted Image Posted Image

#5 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 20 January 2009 - 01:15 AM

Looks like you got out of there just in time. Not good to be stuck up there after dark.
I had to dig myself out once. The snow was very deep and soft if you got of the hard, compact stuff.

#6 Qman

Qman

    Happiness is... no lag!!

  • Moderator
  • 11,119 posts
  • Sumner

Posted 20 January 2009 - 01:20 PM

Jesse, which way did you guys come out? You should have tagged with us. The snow wasn't as soft when we went through. Still very tough when you got off the trail.

#7 jbbvw

jbbvw

    USMB is life!

  • Members
  • 186 posts
  • Tacoma

Posted 20 January 2009 - 09:53 PM

Ken, we decided against the trail we were on and headed up the 311 trail shortly after you, then down through the campground. I don't think we hit the campground until 4:30-5:00. We stopped at the top for a few minutes and after we started heading down I had to stop and fix my shifter. I think the snow was melting quickly in the sun.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users