Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

slow coolant leak thru timing belt cover


  • Please log in to reply
5 replies to this topic

#1 Impreza_WRX_STi

Impreza_WRX_STi

    USMB Regular

  • Members
  • PipPipPip
  • 70 posts
  • Illinois

Posted 20 January 2004 - 08:03 PM

I have a slow coolant leak thru timing belt cover only when eng is running. I'm thinking water pump seal, but it is draing between center cover and pass side cover. HMM

any info is splendid!

Max

#2 tcspeer

tcspeer

    1000+ Super USER!

  • Members
  • 1,444 posts
  • Walnut Springs

Posted 20 January 2004 - 08:13 PM

I would say water pump, mine leaked like that when it went out.

#3 Impreza_WRX_STi

Impreza_WRX_STi

    USMB Regular

  • Members
  • PipPipPip
  • 70 posts
  • Illinois

Posted 21 January 2004 - 08:44 AM

nice!

#4 intrigueing

intrigueing

    USMB Regular

  • Members
  • PipPipPip
  • 115 posts
  • IL

Posted 21 January 2004 - 09:04 AM

I agree, sounds like the wp. I had cam seal on the drivers side that was dripping on the passanger....weird. Where are you in Illinois? I'm in Mchenry - and a civil engineer - where are you going to school?

#5 Setright

Setright

    Elite Master of the Subaru

  • Members
  • 3,176 posts
  • Denmark

Posted 21 January 2004 - 09:49 AM

Could be an external head gasket leak. Stick a pump on the radiator instead of a rad cap and presurise the system, while cold. Look for the drip...

#6 Impreza_WRX_STi

Impreza_WRX_STi

    USMB Regular

  • Members
  • PipPipPip
  • 70 posts
  • Illinois

Posted 21 January 2004 - 10:47 AM

I am going to have to take the cover off, and look saturday.

I go to school at Illinois Valley Com. College. My major is Computer Engineer, my minor is
Civil CAD/Drafter

Your not to far away intriguing!

Max




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users