Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

- - - - -

Positive terminal erosion, overcharging, or what?


  • Please log in to reply
7 replies to this topic

#1 Guest_mtsmiths_*

Guest_mtsmiths_*
  • Guests

Posted 22 June 2003 - 08:01 AM

Had to replace the positive terminal clamp on our '00 Legacy, so corroded that the copper was eaten almost clear thru on one whole side, and couldn't be tightened without breaking it. I've been cleaning and greasing it for over a year, and have to do it about every three months. I know the steel bolt thru the copper clamp and that plastic glove doesn't help (Whatever was Subaru thinking of?), but it sure seems to build up quickly.

I seem to remember from back in the old days (you know, generators, voltage regulators, floor mounted starter switches, 6-volt pos grnd) that rapid build up meant overcharging. The car shows no symptoms (Brighton, so no ammeter) other than the usual O2 sensor CEL toss-offs every few thousand miles.

Any ideas?

#2 Guest_tcspeer_*

Guest_tcspeer_*
  • Guests

Posted 22 June 2003 - 09:32 AM

Our Saturn done this, my thought is battery gas is leaking from around the battery post. You can replace battery or their is the little felt cusions you can put around battery post,you can get them at Wal Mart or auto store, just clean battery good and spray with that chemical stuff they have their in battery dept. We put a new battery on our Saturn along with the felt pads and chemical spray and have not had the problem repeat yet and it has been around six months.

#3 Guest_remarcable_*

Guest_remarcable_*
  • Guests

Posted 22 June 2003 - 02:56 PM

My positive battery terminal is growing new life forms under that red plastic shroud of doom.

I'm not kidding I swear the white/blue crystaline mass formed an eye and winked at me last time I lifted the cover.

I'm scared. :eek:

#4 Guest_Legacy777_*

Guest_Legacy777_*
  • Guests

Posted 22 June 2003 - 03:14 PM

use some baking soda, clean things up very good, then when everything is clean, spray some protector spray on there.

#5 Guest_meep424_*

Guest_meep424_*
  • Guests

Posted 22 June 2003 - 07:41 PM

coke also cleans it well, then rinse w/ water.


mike

#6 Guest_scoobtech_*

Guest_scoobtech_*
  • Guests

Posted 22 June 2003 - 10:29 PM

Its just the battery gassing off , get a good brand & it should take care of it . Maintenance is still going to be required . :cool:

#7 Guest_TinyClark_*

Guest_TinyClark_*
  • Guests

Posted 22 June 2003 - 11:06 PM

You can also lay some old pennies ( the real copper ones) between the + and - posts. This will cause any corrosion to occur on the pennies instead.

#8 Guest_scoobtech_*

Guest_scoobtech_*
  • Guests

Posted 23 June 2003 - 09:41 PM

If that happens , it just shows you need another battery . It should not be able to leak between posts . :cool:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users