Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Will the gage cluster work?


  • Please log in to reply
4 replies to this topic

#1 suby85

suby85

    New User

  • Members
  • PipPip
  • 27 posts
  • Southern Oregon

Posted 19 July 2009 - 09:43 PM

Will the gage cluster out of an 88 XT6 work in a 94 Loyale. The XT6 cluster speedo goes to 140mph and the loyale goes to 130 and the XT6 cluster has the volt and oil pressure gages and the loyel doesn't. other than that, they look the same. the reason I am asking, is my loyale speedy does not work, and the XT6 does.

#2 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,105 posts
  • WA

Posted 19 July 2009 - 09:57 PM

Will the gage cluster out of an 88 XT6 work in a 94 Loyale. The XT6 cluster speedo goes to 140mph and the loyale goes to 130 and the XT6 cluster has the volt and oil pressure gages and the loyel doesn't. other than that, they look the same. the reason I am asking, is my loyale speedy does not work, and the XT6 does.



Umm, dont think so. They are quite different and may even have different harness's.

#3 suby85

suby85

    New User

  • Members
  • PipPip
  • 27 posts
  • Southern Oregon

Posted 19 July 2009 - 10:48 PM

Thats what I thought, but had to ask sence I had the XT6 half parted out and the gage cluster was just sitting there.

#4 Flowmastered87GL

Flowmastered87GL

    WCSS Drunk

  • Members
  • 6,087 posts
  • Portland, Oregon

Posted 20 July 2009 - 01:07 AM

even if you could get them to work the tach would likely be off because of the different number of cylinders. If you want more guages get a GL dash cluster from 85-89

#5 suby85

suby85

    New User

  • Members
  • PipPip
  • 27 posts
  • Southern Oregon

Posted 20 July 2009 - 07:49 PM

Successful at last…used the Speedo internals from the XT6 with the Speedo gears from the Loyale. Works great, no more bounce in the Speedo. I even kept the original odometer.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users