Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Help with air to gas suspension swap 93 Subaru Legacy!!!


  • Please log in to reply
3 replies to this topic

#1 wrxsubaru

wrxsubaru

    1000+ Super USER!

  • Members
  • 1,294 posts
  • Seattle Washington US

Posted 26 January 2004 - 11:47 PM

I was doing the air to gas suspension on my aunts 93 legacy wagon AWD. The front went in really easy, hour for both, but I(friend to) started on the rear and finaly got one rear one out, then started to put the new one in and we tightened it to the top a little, but found the strut would not align up with the hub assembley, it was about 20-30 deggres off being able to go over were you slide the bolts through. What is casing this? Could it be the people who loaded the struts (Firestone) did it wrong? I know the strut was the right side. I know the springs/topmounts/strut are all the right compnets, unless side to side makes a diffrence. AnY ideas my Aunt needs here car running. Thanks

#2 DerFahrer

DerFahrer

    Formerly subyluvr2212

  • Members
  • 2,417 posts
  • Orlando, FL

Posted 27 January 2004 - 01:53 PM

I haven't done rear struts on a Legacy before, but I have a friend who put new rear struts on his 91 Legacy Turbo, and he said you might as well get someone to help you by pulling the hub down so you can align the holes. The swaybar pushes the hub up when you remove the strut, he said.

#3 wrxsubaru

wrxsubaru

    1000+ Super USER!

  • Members
  • 1,294 posts
  • Seattle Washington US

Posted 27 January 2004 - 02:07 PM

I dont have any problems with getting the strut in, I took opff the sway bar. The problem i have is when the strut is in the top mount, the part that conects to the hub is about 20-30 deggres off being able to slide on, and the top mount wont twist. I have done this before on my moms 91 legacy and had no problems.

#4 wrxsubaru

wrxsubaru

    1000+ Super USER!

  • Members
  • 1,294 posts
  • Seattle Washington US

Posted 28 January 2004 - 11:55 AM

The place that loaded the struts did screw up, but they fixed it, and they went very easily.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users