Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

93 Legacy L - Needs Clutch & Advice


  • Please log in to reply
26 replies to this topic

#26 lostinthe202

lostinthe202

    Currently Lost in the 510

  • Members
  • 1,094 posts
  • Oakland, Ca

Posted 22 August 2009 - 04:27 PM

The clips are only for the throw-out bearing, they hold the bearing onto the fork. If the clips break or fall off, the TO bearing causes troubles, what troubles I don't know specifically.

The pilot bearing has no clips, it sits inside the flywheel and it held in place by friction until you mate the engine and trans then it's pinned between the input shaft of the trans and the back of the crank.

#27 mentis

mentis

    Eat, Live, Breath Subaru

  • Members
  • 327 posts
  • San Francisco, CA

Posted 22 August 2009 - 05:07 PM

I figured as much, thanks! So yeah, I guess once those parts come in next week it's time for the install... :banana:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users