Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Help Subaru is down due to flooding


  • Please log in to reply
49 replies to this topic

#26 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 25 August 2009 - 03:34 PM

i'm assuming its an auto right?


it will take you a few trans fluid changed to get the moisture out of the trans... i know some in here hates the lucas trans fix, but that was what saved my new tranny a couple of months back when i went through a deep puddle.. try that when u do change your trans fluid AGAIN

you have to get it all up and running soon.. i'm planning a barrens meet in october lol


Nope it's a manual took FOREVER to find one that was not a Auto.. I brought the car for $400 lol I've gone about 15,000 miles since I got it in March. I'd say I got a pretty good deal.. I might be pulling the engine during the winter and the trans because the rear housing has a little leak (not flood related) and I want to replace my Throw out bearing because it seems like the last owner just replaced the clutch and not the bearing and it drives me nuts hearing it rattle.

I hope to make the meet :D I've yet to get really dirty only took the car offroad a few times in N.C. in some pretty soft somewhat deep sand, did better then I thought.

#27 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 25 August 2009 - 04:35 PM

right now cleaning.. nasty how dirty it is... have not touched the passenger side yet.

Posted Image

#28 Cougar

Cougar

    Elite Master of the Subaru

  • Members
  • 6,340 posts
  • Anchorage

Posted 25 August 2009 - 05:59 PM

I have to commend you on your efforts 1-3-2-4. If that same thing happened to my car I would be looking for a new one.

#29 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 25 August 2009 - 06:06 PM

yeah I was a little scared.. each time I would try to get a code i'd get something else that was complety bogus.. like something that wont start the car like the Crank postion sensor.

It seems like the only possible thing I lost is my XM direct box which was under the passenger seat which got wet.

The word is still out on the ABS module I doubt the carpet will be dry by Friday if so I will reinstall.



but thanks Rooster2 on checking the comprehensive insurance.. I swore when i took out a policy on this car I got it (I wanted full glass) I happen to check and I had none :-/ so I got it now.

#30 Cougar

Cougar

    Elite Master of the Subaru

  • Members
  • 6,340 posts
  • Anchorage

Posted 25 August 2009 - 06:35 PM

Considering the price you paid for the car you could afford to skip the extra insurance. The average shop repair bill is more than you paid for the car.

#31 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 25 August 2009 - 07:11 PM

That is true..

This is one car I can say I enjoy working on as long as it's not water getting in the car.

I plan on replacing the seats at a later date.. as far as mildew smell I can only detect a little where the ECU sits I took the jute padding off it and it's hanging up because the owners before me spilled paint on it that so it's harder to dry.

#32 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 25 August 2009 - 07:16 PM

Fresh picture just drove around about 10 min ago.

Here at idle

Posted Image

#33 Rooster2

Rooster2

    Subaru Master

  • Members
  • 3,685 posts
  • Indianapolis

Posted 26 August 2009 - 10:15 AM

Regarding the carpeting that you are drying. Suggest taking the carpeting to a laundromat. They have those large clothes dryers, just the right size for drying the carpeting. Throw in a few dryer sheets to get the carpeting smelling nice and fresh. The home clothes dryers are too small to do this.

#34 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 26 August 2009 - 10:52 AM

Regarding the carpeting that you are drying. Suggest taking the carpeting to a laundromat. They have those large clothes dryers, just the right size for drying the carpeting. Throw in a few dryer sheets to get the carpeting smelling nice and fresh. The home clothes dryers are too small to do this.


It's not the carpet that's really smelling but the padding..

I manged to get the rear pad smelling OK (no longer makes the whole house smell) It's quicker just to pull the padding up and glue it back on later

#35 frogstar7055

frogstar7055

    USMB is life!

  • Members
  • 159 posts
  • Jacksonville Fl

Posted 26 August 2009 - 06:25 PM

I feel your pain.
My ECU was stone dead.

Posted Image

After I got it pulled out of the pit there was 6-8" of water in it.

Posted Image
Posted Image
Posted Image

Lots of Lysol and drying in the hot sun and no smell.
Got the interior back together just got to get the time and no rain (rains near every afternoon this time of year in Florida) so I can finish doing the wheel bearings.

#36 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 26 August 2009 - 06:46 PM

Holy crap... I did not have standing water like that when I took the carpet up or when it was still down.

And that ECU.. yeah that for sure is gone!

also what is that box beside your E-brake?

Is that a shock sensor?

#37 Bucky92

Bucky92

    Drive Fast, Take Chances

  • Members
  • 3,664 posts
  • New Milford

Posted 26 August 2009 - 06:49 PM

This thread is more reason for why I am not offroading my Legacy again. I was lucky and didnt get water in mine..but I have other problems caused by it.

#38 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 26 August 2009 - 06:52 PM

This thread is more reason for why I am not offroading my Legacy again. I was lucky and didnt get water in mine..but I have other problems caused by it.


I remember you said you had to do your wheel bearings after all of you went to NJ to off road? I think it was more then one person who had to change them on the cars.

I take it mud = failed wheel bearing?


Also the interesting thing out of all of this is it seems like it takes around 6-10 start up's and driving and after that the ECU seems to have enough info

Edited by 1-3-2-4, 26 August 2009 - 06:55 PM.


#39 frogstar7055

frogstar7055

    USMB is life!

  • Members
  • 159 posts
  • Jacksonville Fl

Posted 26 August 2009 - 08:00 PM

That box is the shock sensor for the alarm,unlike the ECU it's sealed tighter that a frogs a$$.

Muddy water = rust.
Bad seals in rear = dead bearing on passenger side.

Changing them both for good measure.

I also pulled the rear CV's apart and the inner joints had water in them.

Water is the enemy:mad:

#40 Rooster2

Rooster2

    Subaru Master

  • Members
  • 3,685 posts
  • Indianapolis

Posted 26 August 2009 - 08:01 PM

Caught your post that you do not have comprehensive auto insurance, so there is no coverage for your flood damage with your auto policy.

Another thought, in your original post, you mention the rain arriving before leaving for work. Was your car at your house or apartment complex when it was water damaged? If so, your home owner's or renters insurance may well cover your loss. It may be worth looking into. As an example, in the past, I have had my car damaged in my home driveway by vandals. Home owner's policy covered the loss. Even though you have done a lot of clean up work yourself, the pictures you have taken are valuable evidence to show an insurance adjuster. Just save your pics!

#41 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 26 August 2009 - 08:06 PM

That box is the shock sensor for the alarm,unlike the ECU it's sealed tighter that a frogs a$$.

Muddy water = rust.
Bad seals in rear = dead bearing on passenger side.

Changing them both for good measure.

I also pulled the rear CV's apart and the inner joints had water in them.

Water is the enemy:mad:


Too bad they can't mount the ECU up where the Air bag module is at.. and that looks like it's well sealed.

#42 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 26 August 2009 - 08:06 PM

Caught your post that you do not have comprehensive auto insurance, so there is no coverage for your flood damage with your auto policy.

Another thought, in your original post, you mention the rain arriving before leaving for work. Was your car at your house or apartment complex when it was water damaged? If so, your home owner's or renters insurance may well cover your loss. It may be worth looking into. As an example, in the past, I have had my car damaged in my home driveway by vandals. Home owner's policy covered the loss. Even though you have done a lot of clean up work yourself, the pictures you have taken are valuable evidence to show an insurance adjuster. Just save your pics!


Yeah I saved all the pictures and I will check into this

#43 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 28 August 2009 - 10:24 AM

I think I need to clean out my IAC the stuff on Monday morning must of left it dirty (never got to clean it a few months ago)

I know I need a new gasket seal for it (Anyone have the part #?) I have some air cleaner spray so where about do I spray it? The one with the fat tube that goes to the air box and where else?

#44 njdrsubaru

njdrsubaru

    is this thing on?

  • Members
  • 1,198 posts
  • Old Bridge, NJ

Posted 28 August 2009 - 11:34 AM

Too bad they can't mount the ECU up where the Air bag module is at.. and that looks like it's well sealed.


i was able to mount my ecu behind the radio.. somehow i squeezed it in there, i tried on another legacy and it didnt work, but mine is still behind the radio and no problems

#45 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 29 August 2009 - 01:05 AM

it looks like it would fit.. the cable was long enough for me to latch it where the lighter was.



#46 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 29 August 2009 - 08:21 PM

I put the carpet back in tonight as well as the ABS module everything is working fine again.

#47 rverdoold

rverdoold

    Subaru Nut

  • Members
  • 651 posts
  • Netherlands

Posted 31 August 2009 - 06:26 AM

For everybody who wants to save his ECU + TCU fill it with liquid silicon which polymerises. Its called Sylgard 184 and is designed to keep water out of electronics and have it more shock-resistant. I used it on friends sailing raceboat for the electronics and never had problems with it even submerging in saltwater.

#48 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 03 September 2009 - 10:19 AM

sounds like a good thing to do if I was really going to go offroad


Also last part of testing here my tank mileage is on par currently to before this flooding happened so the ECU is not doing anything weird.

Friday will be driving up to Rhode Island

#49 Rooster2

Rooster2

    Subaru Master

  • Members
  • 3,685 posts
  • Indianapolis

Posted 03 September 2009 - 11:01 AM

sounds like a good thing to do if I was really going to go offroad


Also last part of testing here my tank mileage is on par currently to before this flooding happened so the ECU is not doing anything weird.

Friday will be driving up to Rhode Island



Glad to hear that you are back on the road again. Still, if it were me, I would replace the ECU. A used one from a wrecking yard can't cost much. A good investment verses breaking down on the open road somewhere.

#50 1-3-2-4

1-3-2-4

    Subaru Mike!

  • Members
  • 3,719 posts
  • Greenwich

Posted 03 September 2009 - 11:06 AM

Glad to hear that you are back on the road again. Still, if it were me, I would replace the ECU. A used one from a wrecking yard can't cost much. A good investment verses breaking down on the open road somewhere.


I do have AAA Gold but I understand what you mean




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users