Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

99 impreza L 2.2l to 2.5l swap


  • Please log in to reply
3 replies to this topic

#1 ubergc8

ubergc8

    New User

  • Members
  • Pip
  • 3 posts
  • West Jordan

Posted 31 August 2009 - 07:53 PM

Hey guys as you can see I am new.

Well I have a 99 Impreza L 2.2l SOHC Auto and it blew up with a horrible sounding crank walk slash rod knock. So i bought a EJ25(3 I believe.) SOHC out of either a 2001-2002 Subaru legacy so all the intake manifold and the connectors were different So i swapped the connectors. and also swapped the drivers side timing pulley and replaced the head gaskets and the head bolts. Since I know they have issues with HG. So now I am stalled at the issue of my car will crank and spark and has compression. It does not have fuel. The fuel stops at the FPR (fuel pressure regulator.)

My injectors when i dummy lighted them, They are not probing. also the cam shaft sensor is not showing up on the dummy light either. I know I have spark but i don't know if it is sparking enough I am running the stock EJ22E ECU and the stock wiring. I also timed it my self and it is timed perfect to what the manual said at autozone. ({Correct me if I am wrong this could be my problem.} When you time the car you time the crank shaft pointing straight up and the timing pulleys straight up with the marks in the pulleys.) Please help my I finally get my parts to put it back together and on the road and I can't (its been in my garage for 1 year with no motor!!!:mad::mad::mad:) Thank you for all your help Im sure this will answer some one elses question or I am just un lucky and get a lemon. lol

Tyson

#2 ubergc8

ubergc8

    New User

  • Members
  • Pip
  • 3 posts
  • West Jordan

Posted 31 August 2009 - 09:00 PM

I checked the spark and I have spark but it only sparks twice with a couple seconds between sparks. and I now have fuel to the injectors but they don't pulse. and the FPR works and is letting fuel through I don't know how much pressure is coming through. and Again I think it might be they crank pulley that the crank sensor runs off of so I am going to change that out on wednsday and re time it. I'll keep you updated oh i also have no power to my camshaft sensor and i checked in the main plugs on the intake side that goes to the ecu there is no power there either.:eek::eek:

#3 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 19,994 posts
  • WV

Posted 31 August 2009 - 10:38 PM

did you cut and splice the wiring, swap harnesses, swap intake manifolds, or what? tell us exactly how you did it with specific details.

i would intall the original cam sprockets and crank shaft sprockets in the engine that's in the car. it will require removing the timing belts to replace the sprocket behind the crank pulley (harmonic balancer).

#4 ubergc8

ubergc8

    New User

  • Members
  • Pip
  • 3 posts
  • West Jordan

Posted 01 September 2009 - 05:07 AM

I am running off of the stock 2.2l ecu and the 2.2l intake manifold and the 2.2l engine harness so all I basically did was swap the long block to a 2.5l. I swapped the timing pulleys but i did not swap the harmonic balancer. I am trying that tomorrow. The motor is out of a legacy its a 2.5l with the SOHC. I am running in to a problem of they car not having power to the camshaft sensor. And the Injectors Having full power and not pulsing. Thanks guys

Tyson




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users