Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

piston rings


  • Please log in to reply
2 replies to this topic

#1 Uberoo

Uberoo

    Subaru Wheeler

  • Members
  • 3,377 posts
  • lewiston,ID

Posted 02 September 2009 - 08:29 PM

I just changed the headgaskets and replaced all the coolant hoses on an EA81 engine that was sitting in a parts car.It seems that the piston rings are sticking because it sat for so long.Anybody know of a way to get the rings to unstick themselves.The engine only runs as long as I spray either down the carb...I dont want to tear the engine down..

#2 GeneralDisorder

GeneralDisorder

    Elite Master of the Subaru

  • Members
  • 20,280 posts
  • Portland

Posted 02 September 2009 - 09:24 PM

If it's running then how did you come to the conclusion that the rings are sticking? If the rings were truely stuck the engine wouldn't turn over let alone run....

Do you mean they aren't sealing? Have you run a comp. check to verify this?

GD

#3 Uberoo

Uberoo

    Subaru Wheeler

  • Members
  • 3,377 posts
  • lewiston,ID

Posted 02 September 2009 - 09:56 PM

the motor does spin like it has no compression. Im thinking the rings are stuck to the pistons and not fully sealing against the walls. Valves mabye but when I turn the engine over by hand I dont hear any air escaping out the intake or exhaust manifold.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users