Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

85 1800cc coil blues


  • Please log in to reply
2 replies to this topic

#1 Dog Town Skater

Dog Town Skater

    New User

  • Members
  • Pip
  • 2 posts
  • MId Coast Maine

Posted 07 September 2009 - 09:49 AM

My 1985 scooby carbed 1800 cc is experiencing coil problems after remounting a new coil last week. The old coil mounting bolt broke so I redrilled a new one next to it. The new hole is putting the coil past horizontal by about 5 degrees with the wire end down. Is this a problem? I can run the car for about a half hour and then I loose spark. Any ideas?

#2 john in KY

john in KY

    1000+ Super USER!

  • Members
  • 1,224 posts
  • KY

Posted 07 September 2009 - 11:04 AM

The next time the engine quits after that 30" run, check how warm the coil is. If the coil is hot to the touch, my guess is you are using the wrong type coil. Coils sort of come in 2 types: high and low impedance. Really can't be swapped. Position of the coil has nothing to do with the problem. As an aside, the coil bracket has to be tightly bolted to the car body as it serves as a ground.

#3 Dog Town Skater

Dog Town Skater

    New User

  • Members
  • Pip
  • 2 posts
  • MId Coast Maine

Posted 07 September 2009 - 12:54 PM

Thanks John! I will check it out. Cheers




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users