Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 4 votes

What Have You Done to your Soobie lately? (Please post in here and keep it going)


  • Please log in to reply
6574 replies to this topic

#3526 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,755 posts
  • Waukesha, WI

Posted 05 January 2012 - 08:43 PM

Had a bling light and tail light blow on me tonight, WTF Legacy!? :rolleyes: these bulbs are only a year old.

#3527 subynut

subynut

    EJ Powa!

  • Gold Subscribers
  • 1,407 posts
  • Sierra Vista, AZ

Posted 05 January 2012 - 08:44 PM

The arm and blade are both off from a honda pilot, I have the part numbers if anyone is interested.


Yes, do tell. :popcorn:


Had a bling light and tail light blow on me tonight, WTF Legacy!? :rolleyes: these bulbs are only a year old.

My sister's GL does the same thing with the front forward facing marker light - lasts 3 months at the most.

Edited by subynut, 05 January 2012 - 08:49 PM.


#3528 frankspinz

frankspinz

    New User

  • Members
  • Pip
  • 3 posts
  • Montreal, Canada

Posted 05 January 2012 - 09:16 PM

I did something for my wife's 2006 Legacy Wagon: I bought her some company ! My own 2005 Outabck Wagon... His & hers Subies ...

Posted Image

My other vehicle is a 2003 Xterra off-road "enhanced"
Posted Image

For the Subaru:
I polished the headlights. Pulled out the heater core that was half blocked by debris, cleaned it out reinstalled everything and put in a cabin air filter. The heater is now operating great ! A must for us in the great white North !

Edited by frankspinz, 05 January 2012 - 09:21 PM.


#3529 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 05 January 2012 - 09:21 PM

Yes, do tell. :popcorn:


76740-S9V-A01 from the honda dealer. I also have heard of getting them off line. I don't know the price yet, as I ordered it through work, and we haven't gotten the bill yet think it's right around $30 for the arm and blade ;) Much better than my rusty worn out one with no spring tension.

#3530 Ricearu

Ricearu

    Official De-Ricer!

  • Members
  • 1,214 posts
  • DFW, TX

Posted 06 January 2012 - 12:29 AM

drug home a $400 special... WHOO HOO! :grin:

P.O. Hit something on the passenger side and trashed the fender, control arm and strut. I thought she was a flipper, but my wife likes it better than the forester (i can see it in her eyes... :-\) It must be the sunroof... Forester soon to be for sale! :rolleyes:

Posted Image

Also overheated my legacy. Driving home from work, pulled into day care and heard it boiling. I let it cool and checked the water and it was full. guess my thermostat is stuck, or my cheap water pump broke...

Edited by Ricearu, 06 January 2012 - 12:35 AM.


#3531 Ricearu

Ricearu

    Official De-Ricer!

  • Members
  • 1,214 posts
  • DFW, TX

Posted 06 January 2012 - 12:40 AM

I put a honda part on mine today :hide: But it is one of the best upgrades I've done, I can see out my rear hatch for the fist time in bad weather! The arm and blade are both off from a honda pilot, I have the part numbers if anyone is interested.


Posted Image

another pic
Posted Image


I will give you my left arm for that spoiler! that is sweet.

#3532 subynut

subynut

    EJ Powa!

  • Gold Subscribers
  • 1,407 posts
  • Sierra Vista, AZ

Posted 06 January 2012 - 12:55 AM

76740-S9V-A01 from the honda dealer. I also have heard of getting them off line. I don't know the price yet, as I ordered it through work, and we haven't gotten the bill yet think it's right around $30 for the arm and blade ;) Much better than my rusty worn out one with no spring tension.


Thanks, now to see if it will fit my GL.:brow:

#3533 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,755 posts
  • Waukesha, WI

Posted 06 January 2012 - 02:14 AM

I think this is the next cheap thing for TW10. Need to run out to the Junkyard anyhow. Maybe I'll find yet another arm that also fits onto the spline.

I will give you my left arm for that spoiler! that is sweet.


Edited by TheLoyale, 06 January 2012 - 12:42 PM.


#3534 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,372 posts
  • Worcester, VT

Posted 06 January 2012 - 10:38 AM

I will give you my left arm for that spoiler! that is sweet.


I cut up one for a second gen, and then screwed it on. I couldn't use and of the factory mounts and had to cut them off, I know a guy that used sticky tape to hold it on, but it blew off going down the highway, so I decided that this was a better option. :D Posted Image

Thanks, now to see if it will fit my GL.:brow:

I don't know if they will or not. Depends if the arm is strait, you may have issues if they are curved like the ones on my ea81's I've been looking for an alternative to those as well.

Edited by 1982gl4, 06 January 2012 - 10:40 AM.


#3535 Stubies Subie

Stubies Subie

    Subaru Fanatic!

  • Members
  • 407 posts
  • Carver, Oregon

Posted 06 January 2012 - 06:54 PM

I took the passenger side steering knuckle over to GD's place so he could drive out the old bearings, (I beat the crud out of them last night and got no-where)

Now that the old bearings are out, it's on to parts cleaning, painting, then start reassembling everything.

Not having to depend on the car as a daily driver, it gives me time to do little extras here and there that I’d normally not be able to do.

#3536 naru

naru

    1000+ Super USER!

  • Members
  • 1,824 posts
  • under the bridge

Posted 06 January 2012 - 07:14 PM

I replaced the rather cracked turbo turbine housing on my EA-81T.
Boost was getting a little sluggish and was accompanied by what I thought was a death rattle at idle.
I thought for sure the rotating parts were beating themselves to death as they are wont to do.

Much to my surprise,upon removal and inspection,they were OK and went back in.
Rattle must have been the wastegate flopping around somehow as it is nice and quiet now w/the new housing.

Boost is back the way it should be-Woo-Hoo!
Back to being a stoplight sleeper.Posted Image

Edited by naru, 08 January 2012 - 06:56 AM.


#3537 987687

987687

    Rally Suby!

  • Members
  • 3,598 posts
  • Northern Maine

Posted 06 January 2012 - 07:58 PM

Hopefully The full size image shows now... Click the link if it's not readable on here.
This is an oil analysis of my GL. Pretty happy with it, all seems to be fine :grin:

http://i190.photobuc...lackstoneGL.png

Posted Image

#3538 mwangix

mwangix

    New User

  • Members
  • PipPip
  • 10 posts
  • kenya

Posted 07 January 2012 - 04:07 AM

looking at the oil analysis the engine seems to be running perfectly despite the age and this truly proves that subaru engines survive a life time

#3539 kanurys

kanurys

    High Altitude GL

  • Members
  • 690 posts
  • Durango, CO

Posted 07 January 2012 - 05:23 PM

When taken care of

#3540 xman

xman

    USMB Regular

  • Members
  • PipPipPip
  • 77 posts
  • Laguna Niguel, CA

Posted 08 January 2012 - 03:33 PM

Installed some OEM jumpseats in the Brat. Had to weld the mount, but everything is legal for passengers (as far as I know). Now I will get a couple of pairs of goggles.

Posted Image

#3541 kanurys

kanurys

    High Altitude GL

  • Members
  • 690 posts
  • Durango, CO

Posted 08 January 2012 - 03:44 PM

Nice. Get Mad Max goggles and mount them with little velcro straps next to the seats.

#3542 xman

xman

    USMB Regular

  • Members
  • PipPipPip
  • 77 posts
  • Laguna Niguel, CA

Posted 08 January 2012 - 03:58 PM

Great idea, I'll put them in a little bag back there. I'm also going to get some plastic covers for the seatbelt reels to help keep them dry now that I have them rehabbed.

#3543 l75eya

l75eya

    Almost has it all figured out

  • Members
  • 1,718 posts
  • Hoboken, NJ

Posted 08 January 2012 - 05:52 PM

New belts, fresh mobil 1 oil + filter on Ben. Now he needs a tire .....

#3544 tundrabrat

tundrabrat

    Eat, Live, Breath Subaru

  • Members
  • 400 posts
  • Anchorage

Posted 09 January 2012 - 12:32 AM

Started on tapping out a dent in the rear right corner of my Brat... Ended up fixing the heater in the wife's suburban.

Not a Subaru but hey, browny points go a long way when you have parts laying all over the place.

#3545 trucking45

trucking45

    USMB is life!

  • Members
  • 164 posts
  • Salem, Or

Posted 09 January 2012 - 02:31 AM

Installed the center consol with the twelve volt outlet that goes below the controls for the heater in my brat yesterday..i'll post pics tomorrow

#3546 trucking45

trucking45

    USMB is life!

  • Members
  • 164 posts
  • Salem, Or

Posted 09 January 2012 - 06:16 PM

Here is the center console with the twelve volt outlet plus some fog/off road lights i installed today:headbang::cool:

Attached Files



#3547 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,139 posts
  • WA

Posted 09 January 2012 - 08:35 PM

Put some miles on the SVX today, I'm up to 10mi since the resurrection.
Had to replace the MAF on it last week, it would only run for 5sec then shut down :-\ The Select Monitor borrowed from capt_r allowed me to track that problem down, thanks Abe!
On the search for a MT EJ starter for my RX now.

#3548 jboymechanic

jboymechanic

    Subaru Fanatic!

  • Members
  • 420 posts
  • Waterford, WI

Posted 10 January 2012 - 08:22 PM

Just got my new front axles, hope the warm weather holds on long enough for me to do the job this weekend.

#3549 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,755 posts
  • Waukesha, WI

Posted 10 January 2012 - 08:58 PM

Just got my new front axles, hope the warm weather holds on long enough for me to do the job this weekend.


HA! Its going down to the 20s after tomorrow. So ya better get wit it son! :cool:

#3550 987687

987687

    Rally Suby!

  • Members
  • 3,598 posts
  • Northern Maine

Posted 10 January 2012 - 09:05 PM

Just got my new front axles, hope the warm weather holds on long enough for me to do the job this weekend.


If I can do both of them in an hour and a half in a parking lot 700 miles from home, you can get it done after work.




2 user(s) are reading this topic

1 members, 1 guests, 0 anonymous users


    Caepman