Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 4 votes

What Have You Done to your Soobie lately? (Please post in here and keep it going)


  • Please log in to reply
6397 replies to this topic

#5326 jonas

jonas

    Subaru Nut

  • Members
  • 1,023 posts
  • Oakridge

Posted 11 July 2013 - 09:53 PM

One more for gits and shiggles.

 

http--,,--//

 

 



#5327 jonas

jonas

    Subaru Nut

  • Members
  • 1,023 posts
  • Oakridge

Posted 11 July 2013 - 09:54 PM

More new pics on previous page!



#5328 Subruise

Subruise

    Official Party Pooper

  • Members
  • 1,470 posts
  • pierce county

Posted 11 July 2013 - 10:02 PM

I had just started to drive to work this morning and was about 0.25 mi from home when my RX gave a shudder like it was stalling and the engine quit. I pulled over and tried to restart it and it cranked, but no start. I popped the hood and checked that the battery and alternator cables were connected and tight and that the distributor was connected. Nothing changed. I unplugged the distributor and cranked for a bit and went to smell the tailpipe to see if I smelled fuel. I couldn't. If the car is backed into a garage, I know this works, but being outside which is not a confined space may be the reason I didn't smell anything. I was out of ideas and so was my dad, who I awoke with a phone call at 0530 because I live 2 hrs ahead of my parents now. I called a repair shop recommended to me and had the car towed there.

 

They called back in the afternoon and said they thought a timing belt had failed. This was very surprising to me because I had inspected the belts a month ago and they were in great condition. I had put them in in December 2009. The shop hadn't actually taken the covers off to check but said the distributor wasn't spinning. They started talking about it being an interference engine and I informed them it was not and they checked their books again and said I was right. They must have looked at a DOHC 1.8 engine. Most people on this site probably have more experience with EA8x engines than all the technicians at a non-Subaru shop. It will be $850 for the repair including the tow, which is hugely expensive but I don't have a spare car nor the time to wait for parts to come in and for me to install them, so I am going to let them fix it.

 

Morals:

 

I should have left the covers off after the work I did a month ago.

I should carry a spare timing belt set and tools in the car.

I should save up a lot of money if I am going to keep it as my DD (at least until I save enough to get something new so the RX is my spare).

get some belts and fix it yourself. youll save hundreds. with a little maintenance its a cheap car to own.



#5329 PlaneDriver

PlaneDriver

    New User

  • Members
  • PipPipPip
  • 34 posts
  • Tucson, AZ

Posted 11 July 2013 - 10:07 PM

get some belts and fix it yourself. youll save hundreds. with a little maintenance its a cheap car to own.

I know I could save a lot, but like I stated before, I don't have the time to wait for a set to arrive nor the time to fix it. If I had a second car, I definitely would do it myself. In this case, it will be cheaper to have them do it because it will be done tomorrow.



#5330 Subruise

Subruise

    Official Party Pooper

  • Members
  • 1,470 posts
  • pierce county

Posted 11 July 2013 - 10:10 PM

not unless you make 400 a day. call a limo to shuttle you around all day, itll still be cheaper



#5331 Twitch de la Brat

Twitch de la Brat

    Village Psycho

  • Members
  • 1,623 posts
  • The Athol of Idaho

Posted 13 July 2013 - 12:41 AM

I know I could save a lot, but like I stated before, I don't have the time to wait for a set to arrive nor the time to fix it. If I had a second car, I definitely would do it myself. In this case, it will be cheaper to have them do it because it will be done tomorrow.

 

They're selling you a job you don't need and could figure out on your own.

Check the fuel pump.

Does it buzz or whine when you turn the key on? And better yet, does it spray fuel?

Pull a plug after cranking and smell it/test it for fuel/oil/antifreeze (touch it to a paper towel and see what color the residue is).

All this could be done in a matter of minutes and possibly save you a ton of money.

 

Twitch

 

PS: To be on topic, I blew a rear speaker in my XT, go me!

Who knew 20 watts could pop a speaker?


Edited by Twitch de la Brat, 13 July 2013 - 12:42 AM.


#5332 subynut

subynut

    EJ Powa!

  • Gold Subscribers
  • 1,397 posts
  • Sierra Vista, AZ

Posted 13 July 2013 - 10:25 PM

Went racing again:

1017526_174892906016436_1275838981_n.jpg

 

I had a blast, didn't place though. :(  Course, if I hadn't blasted through those two gates, I may have had a chance. :wacko:  The course was fast and bumpy which made the PandaWagon's tail fly all over the place. I think I need to loosen things up just a wee in the back. It's quite tail happy.



#5333 BratRod

BratRod

    USMB is life!

  • Members
  • 504 posts
  • Dallas, Texas

Posted 15 July 2013 - 01:58 AM

Well... parts came in the other day:

 

WP_001053_zpsbaabc039.jpg

 

Rotors                  control arm bushings                     rack boots

 

I was doing fine until my father decided to experience first hand how impossible the bushings are to get out without a press. I tried to explain, but no avail. So, right now: I have a really mangled control arm that still has bits of old bushing in it. Needless to say... the other side will be pressed. He had never seen a control-arm bushing without a lip on it before. He was not impressed with the difficulty it gave him. He's never had to send one to be pressed before. He's also never worked on an 80's soob before... Everything else was fine. Except this...

 

WP_001054_zps62c4cc54.jpg

 

This one of the dirtiest cars I have EVER worked on... and it sadly belongs to me. (this is after several cleanings. It was a lot worse)  :rolleyes:  Had someone not left water in the pressure washer over the winter... I might have cleaned it. One step closer to being on the road :D


Edited by BratRod, 15 July 2013 - 02:00 AM.


#5334 Idasho

Idasho

    Lost in the woods....

  • Members
  • 965 posts
  • North ID

Posted 17 July 2013 - 08:29 PM

We had some crazy thundershowers last night.  Wind, hail, lighting/thunder, and a good amount of rain.  I woke up to the subaru covered in pretty much everything.

 

So I gave it a bath this afternoon, rain-x'd the windows, checked fluids, and reinstalled the air conditioning belt and idler.  I had the idler off to replace the bearing that was starting to make noise.

 

 

Then I fired her back up to make sure the AC was working fine, and bumped the idle up a bit.  

 

Sort of funny to sit in such an old silly rig with ICE cold AC   :)

 

julyru.jpg



#5335 alaskaloyale

alaskaloyale

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts
  • Fairbanks Alaska

Posted 22 July 2013 - 08:46 PM

Replaced the front passenger wheel bearings with FAG brand sealed bearings I picked up from a local bearing supply place for $32 apiece (a little steep, but that's the price you pay for not waiting for shipping) I didn't put in new seals since the bearings are sealed, hopefully that doesn't end up being a bad decision, people seem to go back and forth on this forum.

 

Unfortunately, the rubber boots on the ball joint and the tie rod end turned out to be pretty shot, and I'm assuming that the situation is the same on the other side. Those will have to be replaced in the near future, I'll probably do the wheel bearings on the drivers side at the same time.

 

 

After that, I took the car on an 1100-mile roadtrip to Soldotna Alaska and back for a music festival. The car ran pretty well, only losing a little over a quart of oil over that distance and getting almost exactly 30mpg on the highway, going between 65 and 85 the whole way. It does have a shudder in the steering system that is slowly getting worse however, it is almost imperceptible around town and at 55mph, but becomes noticeable around 65 and gets progressively worse with speed. I will need to take care of that soon, my guess is that it will be cured by new ball joints and tie rod ends.



#5336 92_rugby_subie

92_rugby_subie

    Subaru Master

  • Members
  • 1,990 posts
  • Hillsboro OR

Posted 23 July 2013 - 10:08 PM

Traded wheels again... Missed the black look on my car, and I actually LOVE the way these fit and the way they look! Thanks CHRISGPZ!

 

Also went 190 miles each way from Hillsboro to Seattle on ONE tank averaging 75 miles per hour (just over 3K rpms)

 

Without further ado --

 

 

The stance I like, not poking out, but wider tires look GREAT (and Im not rubbing) 205/60/15s

 

 



#5337 crazyman03

crazyman03

    Version 2.2!

  • Members
  • 654 posts
  • Lakewood, CO

Posted 24 July 2013 - 09:42 AM

trying out a make-shift Cold-air box. got my City average MPG from about low 23's to 24-25's MPG :-)

 

1004501_10153188691945727_20889918_n.jpg

 

935092_10153188691770727_1291669415_n.jp

 

-Justin



#5338 SmashedGlass

SmashedGlass

    Eat, Live, Breath Subaru

  • Members
  • 669 posts
  • From CO, stuck in FL

Posted 24 July 2013 - 09:56 AM

Rugby, what wheels are those???



#5339 92_rugby_subie

92_rugby_subie

    Subaru Master

  • Members
  • 1,990 posts
  • Hillsboro OR

Posted 24 July 2013 - 05:49 PM

They are Allied Armament wheels, there are ones that have been remade by SOSFab but having had both, I actually like these better, they are offset better for street driving

 

However for a lifted offroad rig, the SOSFab ones would be a better decision as it puts the wheels out a bit more...

 

Sorry to post the same pic twice, but you can see the difference in the wheels:

Here are the SOSFab versions of the wheel:

 

You can see that on the 215 series tires I poked out A LOT... but its because the center piece of the wheel is flush all the way across... where as this is convex slightly so the wheel sits in more.

Even the Peugeots were on 185 series tires and they poked out the same if not more than these AA wheels.


AA wheels



#5340 SmashedGlass

SmashedGlass

    Eat, Live, Breath Subaru

  • Members
  • 669 posts
  • From CO, stuck in FL

Posted 24 July 2013 - 08:28 PM

Dammit. And AA's are impossible to get ahold of anymore. 



#5341 92_rugby_subie

92_rugby_subie

    Subaru Master

  • Members
  • 1,990 posts
  • Hillsboro OR

Posted 25 July 2013 - 01:31 PM

Im in love with these wheels. Next year when I buy the 07 WRX, Neds getting a new plan. EJ22 swap, rear discs, roof basket, custom front/rear bumpers, fog light overkill, 4 inch lift and bigger tires... he will be the camping/family fun vehicle



#5342 man on the moon

man on the moon

    Subaru Fanatic!

  • Members
  • 609 posts
  • Denver

Posted 25 July 2013 - 09:26 PM

I did something that never EVER happens to me. I went to O'reillys to get stuff for an oil change.

 

Well, I do that frequently. What never happens is I got a really competent parts guy. The book in by the filters didn't list what I needed, so I went to inquire. He asked what car, I explained the motor is not stock and told him what car it came from, and he found the filter without 10 minutes of telling me the car said Loyale on the bumper...it was great. AND when I asked for a length of coolant hose to be thrown in he asked what size ID and how long. Then...he brought me exactly what I needed on the first try. If I go to that O'reilly's again I'm asking for that guy to help me.

 

So in the morning I'm replacing the hose at the thermostat bypass with a smiley face :).



#5343 aba4430

aba4430

    Eat, Live, Breath Subaru

  • Members
  • 333 posts
  • Royston, GA

Posted 28 July 2013 - 06:19 PM

Ordered the last pair of these Hella 550 driving lamps in stock at Amazon today for @$22.50 a piece.  Price has gone up a good bit since my order.  These will replace the ~15 year old Bosch fogs with very pitted glass lenses.  Night time driving should be better.



#5344 Twitch de la Brat

Twitch de la Brat

    Village Psycho

  • Members
  • 1,623 posts
  • The Athol of Idaho

Posted 02 August 2013 - 12:55 AM

Car overheated Tuesday night and I about crapped myself when I watched the temp gauge peg/max out. (digital dash can't exactly peg :P )
So I pulled over, let it cool off and limped it to the house I was watching. Let it cool a bit, and topped it off with water. It built enough pressure in the whole system to literally blow my overflow tank cap off.

Replaced the rad cap as I figured that's what was causing my phantom water loss and over pressurizing of the overflow tank, as well as causing the temp spike before it settles on normal operating temp. I'm still topping up my rad and will be flushing and cleaning the system in the next couple days to reset it back to a 40/60 coolant/water ratio.
Possibly even putting some "purple ice" or "water wetter" in there to make sure this sucker doesn't boil itself over ever.

I'm still hoping I got lucky and didn't pop HG's. Pray to the Subaru gods for me...

Twitch

#5345 JuhaKankkunen

JuhaKankkunen

    Advanced Member

  • Members
  • PipPipPip
  • 87 posts
  • Argentina

Posted 04 August 2013 - 03:38 PM

Starting a rebuild, i must re ring and rebuild valves.

lfav.jpg

ayzo.jpg

#5346 JuhaKankkunen

JuhaKankkunen

    Advanced Member

  • Members
  • PipPipPip
  • 87 posts
  • Argentina

Posted 04 August 2013 - 03:43 PM

The sedan needs a complete rebuild. I ll start with him next week.

Another pic of Wagon EA81

cbzp.jpg

#5347 thesmith

thesmith

    New User

  • Members
  • PipPipPip
  • 33 posts
  • Seattle, WA

Posted 05 August 2013 - 12:21 PM

They're selling you a job you don't need and could figure out on your own.

Check the fuel pump.

Does it buzz or whine when you turn the key on? And better yet, does it spray fuel?

Pull a plug after cranking and smell it/test it for fuel/oil/antifreeze (touch it to a paper towel and see what color the residue is).

All this could be done in a matter of minutes and possibly save you a ton of money.

 

Twitch

 

PS: To be on topic, I blew a rear speaker in my XT, go me!

Who knew 20 watts could pop a speaker?

 

In the audio world it's well known that you should use amplifiers with a higher maximum output than the power handling of your speaker. Some even recommend DOUBLE the power handling of the speaker for higher headroom before distortion.

If you clip the amplifier (drive it to distortion), even with far less than the maximum wattage the speaker is capable of handling, you create square waves which will drive the speaker to maximum excursion and tear the cone apart. "Want to kill your guitar/bass/PA/car speakers? Use a low powered amp and let it run red!"


Edited by thesmith, 05 August 2013 - 12:22 PM.


#5348 81EA81

81EA81

    Eat, Live, Breath Subaru

  • Members
  • 382 posts
  • Spokane,WA

Posted 05 August 2013 - 02:10 PM

JuhaKankkunen

 

That engine sure is clean.

 

http://www.flickr.co...N03/9444020719/

 

While I was out and about my  EA82 suddenly developed a lifter tick. No suprise there.

 

As it turns out, the rear retaining ring on the oil pump pulley had broken free and was allowed to spin against the oil pump body to the point of creating a hole. Surprisingly it didnt dump any oil, just a few drops on the way home. However my timing belts did become oil soaked.

 

While at the yard pulling an oil pump, I looked up to see a NEW radiator. Score! My radiator was original with 300+k miles.

 

I got excited and ended up replacing my oil pump with new oem seals,the old leaky radiator and all of the cooling system hoses, except the little bypass hoses from the carb to the block and thermostat housing.

 

Oh, new timing belts too. I need a pic of the engine bay.


Edited by 81EA81, 05 August 2013 - 02:34 PM.


#5349 Legourde_Nux

Legourde_Nux

    Advanced Member

  • Members
  • PipPipPip
  • 76 posts
  • Santo Domingo, DR

Posted 06 August 2013 - 06:27 PM

You got two EA81 sedans!!!.....that blue one looks sweet!!!!. That engine sure looks clean.



#5350 Uberoo

Uberoo

    Subaru Wheeler

  • Members
  • 3,421 posts
  • lewiston,ID

Posted 07 August 2013 - 08:23 PM

I totaled my car.I was trailering it without an engine and it worked itself loose and fell off the trailer at 50 MPH.Hit a tree about 6 feet wide just a couple inches off center.

http://s109.photobuc...h?sort=3&page=1






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users