Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 4 votes

What Have You Done to your Soobie lately? (Please post in here and keep it going)


  • Please log in to reply
6574 replies to this topic

#6226 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,844 posts
  • Roatán, Honduras.

Posted 19 August 2014 - 12:38 AM

Increasing the timing has helped a lot in driveability. Low end torque has increased. Dieseling has not decreased. 

 

 

Something that has helped to fight dieseling, is to do a Cleanup of the internals,

 

pouring a Seafoam Can to the intake manifold, via vacuum hose.

 

 

 

 

Kind Regards.



#6227 subynut

subynut

    EJ Powa!

  • Gold Subscribers
  • 1,408 posts
  • Sierra Vista, AZ

Posted 19 August 2014 - 09:51 AM

Increasing the timing has helped a lot in driveability. Low end torque has increased. Dieseling has not decreased. 

 

I am surprised that these carbs can function while being so hot. If my holleys and edelbrocks ever got this hot the fuel would boil over right quick. 

 

When I had a Weber on my old EA82, it would diesel some after it was fully warmed up or shutting down after running on the interstate for a while. Most of the time it was during the summer months where the air temps were consistently above 80*.

I ran close to 20* in timing in mine, too.

Mileage was 25-27 when I kept my foot out of it. If I was running WOT all the time, it would drop easily into the low 20s.



#6228 MR_Loyale

MR_Loyale

    20 Years of Ownership. 94-14

  • Members
  • 1,007 posts
  • Seattle

Posted 25 August 2014 - 06:26 AM

Since the passenger  wiper blew off my Loyale Sat during an Indiana downpour on SR 25, I stopped at O'Reilly's in Wabash. Replaced them as a pair and threw the driver side one in the trunk as a spare.



#6229 Silas Cruse

Silas Cruse

    Advanced Member

  • Members
  • PipPipPip
  • 72 posts
  • Dallas Oregon

Posted 25 August 2014 - 11:02 AM

Replaced the Hatch lift struts in my 91 loyale, feels like a new car! ( when i raise the back door )

$29.88 each from Stuarts Auto Supply on Salem.



#6230 ellevehc

ellevehc

    Advanced Member

  • Members
  • PipPipPip
  • 53 posts
  • Bellevue Washington

Posted 25 August 2014 - 12:51 PM

My gl decided to get a bit of a make over by catching on fire. It now rests wherever mac towing took it.

#6231 l75eya

l75eya

    Almost has it all figured out

  • Members
  • 1,724 posts
  • Hoboken, NJ

Posted 25 August 2014 - 02:46 PM

My gl decided to get a bit of a make over by catching on fire. It now rests wherever mac towing took it.


Wow. ... Pics?

Mine tried twice to burn itself down. Had to rip out one flaming alternator and on another occasion rip out the battery to keep some wires shorting

#6232 Tom0

Tom0

    Advanced Member

  • Gold Subscribers
  • PipPipPip
  • 52 posts
  • Dunedin NZ

Posted 26 August 2014 - 01:15 AM

If purchasing a friend for my wagon counts, then I've done something. Bought a 1983 1600cc leone sedan (glf-5). Its in alright condition, a bit rough but no rust  so that's good.


Edited by Tom0, 26 August 2014 - 01:20 AM.


#6233 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,844 posts
  • Roatán, Honduras.

Posted 26 August 2014 - 10:57 AM

... Bought a 1983 1600cc leone sedan (glf-5). Its in alright condition, a bit rough but no rust  so that's good.

 

Sounds Good!

 

Please, share photos of that Subaru, 

 

As long as you Can...

 

We Love Photos here.

 

Kind Regards.



#6234 Scooner

Scooner

    New User

  • Members
  • 517 posts
  • Cheyenne, Wyoming

Posted 26 August 2014 - 09:51 PM

20140823_084917.jpg

Changed a stuck thermostat in the parking lot of Napa in Jackson, Wy...in the rain, at the end of an awful trip, and with a wicked chest infection. Just to drive 7 hours home aye yi yi.

#6235 Tom0

Tom0

    Advanced Member

  • Gold Subscribers
  • PipPipPip
  • 52 posts
  • Dunedin NZ

Posted 28 August 2014 - 12:06 AM

Pictures!

Girlfriends named her Lucy, Lucy the leone.
So far on my list of things to be fixed;
both cvs
Heater
find an am/fm radio
window winders

Passenger (errr driver) wing mirror
Passenger front guard dent and bumber.

 

Starts and runs great though so im pleased with that.
 

http://puu.sh/bb3B0/e099f075b6.jpg

http://puu.sh/bb3zG/6941d5ebae.jpg
http://puu.sh/bb3Ag/7878d8c78c.jpg



#6236 Leeroy

Leeroy

    Old boxer tricks!

  • Members
  • 510 posts
  • Albury, NSW, Australia

Posted 28 August 2014 - 05:00 AM

Lucy looks good! Interesting colour too, don't think we got that in Australia.

#6237 wagonist

wagonist

    User Awaiting Email Confirmation

  • Members
  • 500 posts
  • Sydney, Australia

Posted 28 August 2014 - 06:25 PM

Agree. Is that a blue or a green?



#6238 l75eya

l75eya

    Almost has it all figured out

  • Members
  • 1,724 posts
  • Hoboken, NJ

Posted 28 August 2014 - 06:37 PM

Fixed my alternator, maxima alternator was sitting loose. Couple washers took care of that. Oil change with a quart of Lucas oil treatment and gear oil change in the trans with another quart of Lucas as well. Gear oil was still relatively clean but lots of bits of metal on the drain plug again. :-\ the 5 speed is still working despite the racket it makes though.

 

Looking forward to meeting mr Loyale tonight as he iscurrently  making his way down from Maine. Can't wait to see his Loyale and the chromed out motor in it! 

Attached Files



#6239 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,844 posts
  • Roatán, Honduras.

Posted 28 August 2014 - 07:29 PM

... Looking forward to meeting mr Loyale tonight as he is currently  making his way down from Maine. Can't wait to see his Loyale and the chromed out motor in it! 

 

Awesome!

 

You can share photos here:

 

~► http://www.ultimates...eel-pics-of-us/

 

 

 

 

Agree. Is that a blue or a green?

 

Looks light Green to me.

 

Nice EA71 Sedan.

 

Kind Regards.



#6240 Mykeys Toy

Mykeys Toy

    Subaru Master

  • Members
  • 2,057 posts
  • South Prairie, Wa

Posted 28 August 2014 - 09:36 PM

Lucy will clean up nicely!  I don't see anything major wrong with her.  Makes me wanna hurry things along with mine..

 

On to other news

 

Went to adjust valves and got the good times going with permatex removal..  I guess I wont be finishing today. Dang it!



#6241 l75eya

l75eya

    Almost has it all figured out

  • Members
  • 1,724 posts
  • Hoboken, NJ

Posted 29 August 2014 - 02:28 AM

Met Mr_Loyale and his awesome Loyale.

Good times! Bad rump roast road trip he is on!

Geeked out Subaru style and snapped some pics. Best we could do at night!

Attached Files



#6242 Tom0

Tom0

    Advanced Member

  • Gold Subscribers
  • PipPipPip
  • 52 posts
  • Dunedin NZ

Posted 29 August 2014 - 03:20 AM

Its a green, Sea mist green according to the colour label. Its NZ new i believe so possibly painted here?  Found that the whole passenger side footwell was very wet so pulled the seats/carpet worried about it being rusted on the inside, turns out to be fine. So now going to clean what little surface rust is there and possibly spray/ paint a floor liner while all the carpets off?



#6243 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,844 posts
  • Roatán, Honduras.

Posted 29 August 2014 - 06:48 AM

... spray/ paint a floor liner while all the carpets off?

 

That is Good idea.

 

 

 

...Geeked out Subaru style and snapped some pics. Best we could do at night!

 

Awesome

 

Thank you for Sharing pics.

 

Kind Regards.



#6244 subynut

subynut

    EJ Powa!

  • Gold Subscribers
  • 1,408 posts
  • Sierra Vista, AZ

Posted 29 August 2014 - 09:05 AM

Replaced a flaky injector in Wedge. It was driving me mad: When cold, it was fine. Once it was halfway warmed up, I'd loose a cylinder. But if I continue to drive it, it would clear up after fully warmed up for 10 miles or so. So weird. But, it's solved now. :banana:



#6245 Dee2

Dee2

    USMB Regular

  • Members
  • 282 posts
  • US

Posted 30 August 2014 - 11:27 PM

Passenger side front axle outer boot ruptured so I decided to replace the whole axle since it had been in there for several years and I suspected it to be the remaining source of the front end noise.  Replacing it  finally got rid of all that annoying noise. All smooth running and quiet now. 

 

Turned out the shop that did the axle last time had put in the wrong axle type ! 



#6246 MR_Loyale

MR_Loyale

    20 Years of Ownership. 94-14

  • Members
  • 1,007 posts
  • Seattle

Posted 31 August 2014 - 10:00 AM

After putting on 6,570 miles in the month of August, I changed the oil and filter (using synthetic). We will see how many miles the trurn trip takes.


Edited by MR_Loyale, 31 August 2014 - 11:48 AM.


#6247 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 5,844 posts
  • Roatán, Honduras.

Posted 31 August 2014 - 12:01 PM

... I changed the oil and filter (using synthetic). ...

 

Which Brands, and oil's SAE Number?

 

I Run my "BumbleBeast" with 20W~50 since New...

 

With Purolator 10028 Oil Filter.

 

Kind Regards.



#6248 l75eya

l75eya

    Almost has it all figured out

  • Members
  • 1,724 posts
  • Hoboken, NJ

Posted 31 August 2014 - 05:15 PM

Got to cracking on trying to nail down my girlfriend's Loyales intermittent non start conditions. Put in a new, remanufactured starter from autozone (found an etching on the old one from whomever must have installed it. Initialed with the date 7/11/03), cleaned up all connections, ground, 12v, replaced the connector that attaches to the 1/4" spade terminal as it was loose. Car still wouldn't start with electrical accessories on. Swapped batteries with my GL and seems to be okay for now. Only time will tell.

Also replaced the shoes and shoe springs on the rear and repacked the bearings with fresh grease.

Edited by l75eya, 31 August 2014 - 05:17 PM.


#6249 Mykeys Toy

Mykeys Toy

    Subaru Master

  • Members
  • 2,057 posts
  • South Prairie, Wa

Posted 31 August 2014 - 06:47 PM

I finished my valve adjustment.. Took my a little longer since I wanted to clean the covers before reinstall.  I double checked each one after adjustment so they should be spot on.  I have got to figure out why I have lifter noise on one side.. It's gonna drive me crazy.  I had it before valve adjustment and still have it..  I did find one intake a little loose and one exhaust was too tight (same area the noise is coming from).  Wonder if it will resolve itself with a little driving?

I guess I will ask in the regular forum.


Edited by Mykeys Toy, 31 August 2014 - 06:50 PM.


#6250 jonas

jonas

    Subaru Nut

  • Members
  • 1,056 posts
  • Oakridge

Posted 31 August 2014 - 07:06 PM

Fresh bed liner, repainted the roll bar, and got the seats in.

http--,,--//

 

http--,,--//

 

Used all stainless hardware for ease of removal and to keep rust down.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users