Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 4 votes

What Have You Done to your Soobie lately? (Please post in here and keep it going)


  • Please log in to reply
6104 replies to this topic

#976 '84 Flat-Four

'84 Flat-Four

    Eat, Live, Breath Subaru

  • Members
  • 255 posts
  • South Jersey

Posted 06 April 2010 - 09:55 AM

6 lug swap with the high quality work from BOSS (6-lug-swap mod service in Vendor section)... highly recommend it!
Thanks Bill! :)

Here's a pic of my new setup. Need to do a little bfh work and trimming as it rubs quit a bit... but these are 235/75 R15s (roughly 28") on toyota rims and stock height (cranked up). Picked up rims w/ tires locally for $10 each :banana:
I'll probably throw on 215s or 205s... not sure yet.

I think a lift is next... :grin:

Attached Files



#977 Txakura

Txakura

    Not the Stig

  • Gold Subscribers
  • 981 posts
  • Albion, WA

Posted 06 April 2010 - 10:37 AM

Swapped stereos, put a decent one in the RS and put an okay one in the RX. SO, I have tunes -again- . :banana:

#978 Goobysoobs

Goobysoobs

    USMB is life!

  • Members
  • 165 posts
  • Raleigh, NC

Posted 06 April 2010 - 02:33 PM

Got replacement bolts for the Yakima rack, and charged up my self jumpstarter and refilled the back windshield washer reservoir.

I may just cut it out and re weld it... definitely will start with the front fenders and work my way back. Also the A/C doesn't blow cold air so would it better to replace the A/C or just take it to a shop to be refilled?

#979 dhise

dhise

    USMB is life!

  • Members
  • 204 posts
  • Detroit

Posted 06 April 2010 - 04:29 PM

Snapped a clutch cable yesterday...luckily I had one waiting to go in because the old one was a bit too stiff to be right. Now I have a nice easy clutch pedal again! :banana:

#980 xbeerd

xbeerd

    dookin'

  • Members
  • 1,022 posts
  • Milwaukee, WI

Posted 06 April 2010 - 08:03 PM

Got $3,000 in goodies not including the bumpers roof rack and tail light guards that are coming this month from HTI


im sure there's more


oh yeah! well, i got a AM FM radio with one speaker! :lol:
************ man, that stuff costs twice as much as my whole damn car!

#981 Twitch de la Brat

Twitch de la Brat

    Village Psycho

  • Members
  • 1,533 posts
  • The Athol of Idaho

Posted 06 April 2010 - 08:30 PM

Swapped hubs on Xandra's drivers side, rear.
No more bearing rumble while driving down the road! :banana:
I was actually able hear the person next to me while driving.

Had to swap the studs between the hubs because the other ones were
stretched and some of them were snapped off :eek:
My dad showed me a good way to get my studs to sink into the hub.
A nice thick nut with built in washer, a well greased stud and a lugnut, and I
got my studs to sink into the hub without issue :)

Twitch

#982 mudduck

mudduck

    Subaru Nut

  • Members
  • 701 posts
  • Asheboro NC

Posted 06 April 2010 - 09:19 PM

Aligned my front end sunday after replacing the front knuckles, wheel bearings and a driverside tie rod. Hopfully no more funky tire wear.

#983 subynut

subynut

    EJ Powa!

  • Gold Subscribers
  • 1,374 posts
  • Sierra Vista, AZ

Posted 06 April 2010 - 09:49 PM

Prepared the front struts and found all the missing hardware for the 5 lug swap. Took the front hubs to the machinist to have them looked at and the bearings replaced. Found both hubs were out of spec and would cause pre-mature failure of the bearings. :eek: Found bearings, ordered 2 new hubs, got one in today, and ran all over town looking for the proper seals. I got one hub assembly back, still waiting on the other. Cleaned one brake caliper I think I may have a sticking caliper assembly...gonna look into that tomorrow.
Assisted with bleeding the brakes on my brother's XT6.
Non subaru related: changed the tranny and transfer case fluids on my F350 - wow, what a mess that was!

True2Blue:
That's some serious electrical draw you will be installing. I hope you plan on putting a bigger alternator in there. I was poping 65A alternator (alternator is rated at 60A) fuses with a 900W audio system, aux lights, dual high powered electric cooling fans, and a SPFI conversion. Just lettin' ya know! ;)

#984 True2Blue

True2Blue

    SU<3ARU

  • Members
  • 776 posts
  • Belfair WA

Posted 07 April 2010 - 12:25 AM

oh yeah! well, i got a AM FM radio with one speaker! :lol:
************ man, that stuff costs twice as much as my whole damn car!


i feel ya.. i know i bought it for 5k last year when i was iraq.. all NEW. so i depreciated it a bit for age.

my 87 has a perfect condition stereo with all working speakers someone offered my $10 for it...:-\

#985 True2Blue

True2Blue

    SU<3ARU

  • Members
  • 776 posts
  • Belfair WA

Posted 07 April 2010 - 01:15 AM

True2Blue:
That's some serious electrical draw you will be installing. I hope you plan on putting a bigger alternator in there. I was poping 65A alternator (alternator is rated at 60A) fuses with a 900W audio system, aux lights, dual high powered electric cooling fans, and a SPFI conversion. Just lettin' ya know! ;)


i know ill be ultimately upgrading to 140amp gm alternator but for now im gonna do the maxima 90amp

#986 vagen

vagen

    Subaru Fanatic!

  • Members
  • 401 posts
  • Charlotte, NC

Posted 07 April 2010 - 04:53 AM

easy equation amps x Volts = Watts you might just scare yourself.

#987 True2Blue

True2Blue

    SU<3ARU

  • Members
  • 776 posts
  • Belfair WA

Posted 07 April 2010 - 05:24 AM

its okay people im 21 i know a few things not alot but a few. and i just removed this system out of my truck it was hooked up and bumpin im not stupid ive ran it before so i know its limits..

i have a few diplomas that say i know whats up as well. no more common sense bashing on true2blue please

Edited by True2Blue, 07 April 2010 - 05:30 AM.


#988 xbeerd

xbeerd

    dookin'

  • Members
  • 1,022 posts
  • Milwaukee, WI

Posted 07 April 2010 - 08:44 AM

atleast tho, with the capacitors in there you should save a little bit of draw on the system. i would bet you'd be just fine with a 90 amp alternator.

I ran my old system in my ford probe 2x1000watt amps w/ 2 1farad caps wired up and it was fine, except when there was a looooong bass sound while driving with my headlights on. never killed the car, but it wanted to!:)

be sure to post some pics (progress and finished product) of the install! i'd be down to see it in all its glory.

#989 True2Blue

True2Blue

    SU<3ARU

  • Members
  • 776 posts
  • Belfair WA

Posted 07 April 2010 - 09:17 AM

atleast tho, with the capacitors in there you should save a little bit of draw on the system. i would bet you'd be just fine with a 90 amp alternator.

I ran my old system in my ford probe 2x1000watt amps w/ 2 1farad caps wired up and it was fine, except when there was a looooong bass sound while driving with my headlights on. never killed the car, but it wanted to!:)

be sure to post some pics (progress and finished product) of the install! I'd be down to see it in all its glory.


thank you! my stock gm alternator did just fine with the subs POUNDING for 10 minutes while fine tuning the amps and it was under 90amps...

i know what it will handle but i don't argue too much on here, i get nowhere fast. i just take the input and use whats useful lol.

im going to start the install tomorrow im waiting on door speakers an amp kit and a sub box.... today.. im ordering my bumpers:banana:

i bought paint and clear coat along with caulk for my electrical connections mainly grounds im cleaning all the surfaces then sealing them after connected.

pics coming tonight

#990 Nomad_Brad

Nomad_Brad

    USMB is life!

  • Members
  • 195 posts
  • Caldwell

Posted 07 April 2010 - 03:50 PM

error

Edited by Nomad_Brad, 07 April 2010 - 04:24 PM.


#991 Nomad_Brad

Nomad_Brad

    USMB is life!

  • Members
  • 195 posts
  • Caldwell

Posted 07 April 2010 - 03:52 PM

Went to the junk yard and seen a sight that I have never seen before, I WISH there was all four but there was only 1, What a cock tease, anyway anybody know what rims these are?

Posted Image

Posted Image

#992 Twitch de la Brat

Twitch de la Brat

    Village Psycho

  • Members
  • 1,533 posts
  • The Athol of Idaho

Posted 07 April 2010 - 08:04 PM

Went to the junk yard and seen a sight that I have never seen before, I WISH there was all four but there was only 1, What a cock tease, anyway anybody know what rims these are?

Posted Image

Posted Image


Those are Cal/Masters
Might wanna check out the subaru's of the 80's site a little more often ;)
http://www.indysworl...els/wheels.html

Twitch

#993 vagen

vagen

    Subaru Fanatic!

  • Members
  • 401 posts
  • Charlotte, NC

Posted 08 April 2010 - 05:10 AM

I understand the ceiling being high on a sound system, that's where the quality lives. I am glad you are not the typical crank it till your deaf bass head they give high powered stereos a bad name. I am eagerly awaiting photos of your install I need ideas

#994 True2Blue

True2Blue

    SU<3ARU

  • Members
  • 776 posts
  • Belfair WA

Posted 08 April 2010 - 05:40 AM

jesus me too.. im waiting on my 0 guage dual amp kit to come along with my new box and rear door speakers..

the yellow top handles the draw pretty damn good. and 18 farads give the battery protection as well as the alternator

my pics are continuing on this thread

http://www.ultimates...t=110907&page=2

#995 Nomad_Brad

Nomad_Brad

    USMB is life!

  • Members
  • 195 posts
  • Caldwell

Posted 08 April 2010 - 12:44 PM

Those are Cal/Masters
Might wanna check out the subaru's of the 80's site a little more often ;)
http://www.indysworl...els/wheels.html

Twitch


Whoa, thats a crazy name for a rim....thanks for the help, harry

#996 subaruguru

subaruguru

    Oldschool Cool

  • Members
  • 1,642 posts
  • Yakima Wa,

Posted 08 April 2010 - 09:21 PM

LOST REVERS IN MY CAR :( kinda sucks...

#997 True2Blue

True2Blue

    SU<3ARU

  • Members
  • 776 posts
  • Belfair WA

Posted 09 April 2010 - 12:48 AM

all new windshield wiper (Bosch uni bar style) and today i blew a heater core line so i replaced both of those:-\

whats next:confused: lol

#998 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,635 posts
  • Waukesha, WI

Posted 09 April 2010 - 01:32 AM

LOST REVERS IN MY CAR :( kinda sucks...


You lost some refer in your car..? What? :lol:

#999 subynut

subynut

    EJ Powa!

  • Gold Subscribers
  • 1,374 posts
  • Sierra Vista, AZ

Posted 09 April 2010 - 02:36 PM

Oh, the 5-lug woes....having interesting issues with this project. The rear was easy, but the front? Oh my...
Out with the old:
Posted ImageCan you tell this poor roo hasn't been out and about in a while?

Pulled it all out...drilled out the holes in the crossmember for the XT6 control arm to 15/32" and installed the control arm:
Posted Image
I had to pull the sway bar and the steering rack out to give me enough room for the drill so I could drill out the holes for the bigger bolt. I used 2 bolts from the my parted out Sportage to bolt it to the car.:eek:
All was going well till I ran into this little hiccup:
Posted Image
Humm.. that won't do....
Posted Image
Oh, most definitely not! 92' Legacy springs are WAY too wide!
So, a "quick" run to Tucson and found these:
Posted Image
95 Impreza sedan spring and Legacy strut - much better! :)

After getting that straightened out, I attempted to install the CV axel, but it's too long! It's at full compression with the suspension at full droop. Somethin's wrong here....I checked Napa's web site, since that's where we got them from, and the part number of the half shaft I have, is the shorter of the two axles Napa lists :confused: What's odd, is the used Legacy axle we pulled from the donor car, is shorter than this one.:confused::confused::confused:
Off to more solving of this interesting puzzle....
Well, after Perry Mason is over.:grin:

#1000 subaruguru

subaruguru

    Oldschool Cool

  • Members
  • 1,642 posts
  • Yakima Wa,

Posted 10 April 2010 - 11:06 AM

UPDATE ON MY TRANS and a bit weird at that pushed my car out of the driveway to move it went around the block and for gits and shiggles i put it in reverse low and behold the car went backwards... ? WTF drove it around worked fine all day but i go out to the car thismorning fire it up put it in reverse and the damn thing wont move but after i drive it for a bout 5 min. shure as ************ it works im at a loss its a Turbo 3.7 5sp SR 4x4 trans. anyone had this happen?

Rob.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users