Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 4 votes

What Have You Done to your Soobie lately? (Please post in here and keep it going)


  • Please log in to reply
6107 replies to this topic

#176 backinbrat

backinbrat

    USMB is life!

  • Members
  • 194 posts
  • sussex, england

Posted 12 October 2009 - 01:35 PM

nice horns man! lol

well, the engine build is well under way, engine came out today, stipped all the bits off it a want, such as the dual port heads, and alll that shizzle, and the new block with the uprated cam was put together as well, should be all in and running by the end of this week, all finished off with a full stainless, 1 1/2 - 2 - 2 1/2 exhuast system with 2 boxes, should be alright! haha! piccys of the progress will be posted tomoz

Edited by backinbrat, 12 October 2009 - 01:37 PM.


#177 jg09

jg09

    USMB Regular

  • Members
  • PipPipPip
  • 66 posts
  • Maple Falls

Posted 12 October 2009 - 01:38 PM

I finally got a tire to replace the little one i had on it. Got to take the FWD fuse out of it, which made loose gravel driving amazingly fun again.

#178 Scott in Bellingham

Scott in Bellingham

    Lets go wheelin!!

  • Members
  • 3,576 posts
  • Bellingham

Posted 12 October 2009 - 01:52 PM

wheeled

Posted Image




Posted Image

#179 vagen

vagen

    Subaru Fanatic!

  • Members
  • 401 posts
  • Charlotte, NC

Posted 12 October 2009 - 02:21 PM

exhaust parts mmmmmmm 2.5 inch mmmmm


Posted Image

Posted Image

the black box is my new boost controller

#180 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,104 posts
  • WA

Posted 12 October 2009 - 03:03 PM

Allrighty.... Well, I've been off the board awhile 'cause the XT was down, haven't touched the turbo coupe and haven't done anything with the Brat except use it for camping. So, after the rebuilding of the sunroof in my 87.5 XT GL10 (unicorn) I got to drive it twice before it lost a rod. Second time, same cylinder, brand new crank and rods. Wasn't happy. Decided I was done with E18's. For the last year, I've been piecing everything together for an EJ22 swap and I spent less than $500 to do it. I now have everything to do it. Not just a standard swap... NA EJ22 with a turbo add on that will run 6-8lbs of boost, a knock light, a 16 pass oil cooler with AN8 fittings to match the adapter, a stock Subie AWIC set up that will also cool the turbo instead of using the engine to do it (and I just snagged another AWIC off Evil Bay today) All new plumbing for the intercooler, bigger injectors, boost controller with built in timer, nitrous shot controller at 0psi (still deciding on whether or not to use THAT feature :grin:) and another 12v controlled output for whatever... Got a 4 gauge pillar pod, AFR, EGT, oil temp and pressure guages. A new Pioneer USB/bluetooth deck, speakers and amps. It's amazing the things you can barter for! Lucky for me, I didn't get a chance to install all the interior trim after the sunroof escapade. Still looking for an LSD 3.70 diff, but it's gonna run without it. Someone was kind enough to lend me their completed wiring harness to speed up building mine, so once I'm done with that, I start assembling! Should be in the next couple of weeks... :banana:

Its ok to throw my name out there :D

get a willys


We finally agree on something :rolleyes:

#181 cmiller

cmiller

    Flat 4

  • Members
  • 735 posts
  • Tigard, OR

Posted 12 October 2009 - 05:00 PM

I started the EJ22 swap today, pulled the EA82 out and got the power steering rack fixed. http://www.ultimates...t=103355:Flame:

#182 mountain brat

mountain brat

    USMB is life!

  • Members
  • 132 posts
  • tieton,wa

Posted 12 October 2009 - 09:55 PM

been busy finished 6lug,rear disc,pitch stopper,radiator and fans they fit in stock side and kept ac,starting exhaust and finish wiring

Attached Files



#183 mountain brat

mountain brat

    USMB is life!

  • Members
  • 132 posts
  • tieton,wa

Posted 12 October 2009 - 09:58 PM

also have pics of my pitch stopper but it wouldn't let me post it here with others sorry

#184 LPGsuperchargedBrumby

LPGsuperchargedBrumby

    Fully retarded and low on compression

  • Members
  • 655 posts
  • Dunedin, NZ

Posted 12 October 2009 - 09:58 PM

cut the front axles off at the hubs with a 5" grinder with a cutoff wheel:banana: an pulled the axles....it was a bit brutal but i needed to be moving again as soon as possible

#185 backinbrat

backinbrat

    USMB is life!

  • Members
  • 194 posts
  • sussex, england

Posted 13 October 2009 - 08:15 AM

exhaust parts mmmmmmm 2.5 inch mmmmm


Posted Image

Posted Image

the black box is my new boost controller


ar yeah man, thats gonna be sexy when thats all on!

#186 xbeerd

xbeerd

    dookin'

  • Members
  • 1,022 posts
  • Milwaukee, WI

Posted 13 October 2009 - 10:50 AM

Thats cool, yea you might be a tooth off on the T-belts and that could be it, or maybe the IAC or MAF is dirty.

It wouldn't happen to be a Sedan, would it? Cause I've seen a dark gray sedan once around downtown (Old world 3st) when I had to go to the Coby abbot building. As for the white one, no havn't seen it. I don't go in milwaukee much or atall. My mom did see a dull light blue EA82 wagon a few times in her parking lot at work by state fair. I don't see very many if any old Subarus :( one or two wagons from time to time (Old people driving them Lol)

Well, If you ever see mine, be sure to beep your horn, flick your lights, yell. whatever it takes lol (Beleive me, you can't miss me Lol) Pictures in my profile :)

btw, T-belts are fairly easy to do, Miles Fox has a great right up about it and other things on http://www.Trashwagon.com He was also in Milwaukee and Butler.

-Tom


Nah, mines a wagon, usually parked downtown behind the Hyatt. I was hoping to do the timing belts before it got cold... looks like i might be a little late! i'll look for ya man!

#187 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,635 posts
  • Waukesha, WI

Posted 13 October 2009 - 11:39 AM

What I did today! :banana:

Posted Image

Posted Image

Posted Image

Posted Image

about 1/2 ft. deep grass mud mix :banana:
Posted Image

Posted Image

So guys, are these better then my last off-road pictures Hahaha! :grin:

-Tom


#188 bheinen74

bheinen74

    Banned

  • Banned
  • Pip
  • 0 posts
  • central Iowa

Posted 13 October 2009 - 12:37 PM

do the cops care your rear plate is not clear, due to tire mount.

#189 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,635 posts
  • Waukesha, WI

Posted 13 October 2009 - 01:37 PM

do the cops care your rear plate is not clear, due to tire mount.


Lol, I thought about that when I put the bumper on. So far no one seems to care or notice. thats one reason I'm not gonna put a spare tire on it, I'll juts mount it in the rack Safari style :banana:

I mean its not really blocked, you can see 926 RCN, so they can (you know what) Haha. Speaking of cops, I got pulled over for not having the covers on my top lights :rolleyes: Can't do anything these days. I'm supprized they don't say a lift is not street leagle :lol:

-Tom

#190 xbeerd

xbeerd

    dookin'

  • Members
  • 1,022 posts
  • Milwaukee, WI

Posted 13 October 2009 - 01:55 PM

leagle?

#191 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,635 posts
  • Waukesha, WI

Posted 13 October 2009 - 01:59 PM

leagle?


Lol, nit picker huh?

-Tom :grin:

#192 xbeerd

xbeerd

    dookin'

  • Members
  • 1,022 posts
  • Milwaukee, WI

Posted 13 October 2009 - 02:01 PM

Lol, nit picker huh?

-Tom :grin:


<-- Grammar Cop :lol:

#193 vagen

vagen

    Subaru Fanatic!

  • Members
  • 401 posts
  • Charlotte, NC

Posted 13 October 2009 - 09:59 PM

Installed the nice 2.5 in exhaust
Posted Image
Posted Image

#194 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,635 posts
  • Waukesha, WI

Posted 13 October 2009 - 10:38 PM

Installed the nice 2.5 in exhaust
Posted Image
Posted Image


Boy that RX is on the ground! Does the mid-pipe hit going over speed bumps? you wouldn't have a shot of the whole car huh? Wanna see it :)

-Tom

#195 vagen

vagen

    Subaru Fanatic!

  • Members
  • 401 posts
  • Charlotte, NC

Posted 13 October 2009 - 11:02 PM

Posted Image

#196 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,635 posts
  • Waukesha, WI

Posted 13 October 2009 - 11:07 PM

Hey thats looks pretty good, I like the roof scoop (Usable?) are you still running the EA82?

Make sure you get a video of that puppy with the 2.5" exhaust!
-Tom

#197 vagen

vagen

    Subaru Fanatic!

  • Members
  • 401 posts
  • Charlotte, NC

Posted 13 October 2009 - 11:19 PM

oh I plan to I can tell you it has helped throttle response a bit and the boost is now 9psi without adding in the controller.

#198 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 6,635 posts
  • Waukesha, WI

Posted 14 October 2009 - 12:19 AM

oh I plan to I can tell you it has helped throttle response a bit and the boost is now 9psi without adding in the controller.


Nice, at least your not over boosting. :)

#199 AWD TURBO!

AWD TURBO!

    USMB is life!

  • Members
  • 205 posts
  • vancouver

Posted 14 October 2009 - 01:14 AM

2 1/2 with no cat free flow:grin:


[ATTACH]6988[/ATTACH]

[ATTACH]6989[/ATTACH]

[ATTACH]6990[/ATTACH]

[ATTACH]6991[/ATTACH]

Edited by AWD TURBO!, 14 October 2009 - 04:05 AM.


#200 vagen

vagen

    Subaru Fanatic!

  • Members
  • 401 posts
  • Charlotte, NC

Posted 16 October 2009 - 08:51 PM

installed the boost controller YAY 11psi and no cut wooohoo!!!!!! :banana:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users